summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-03-21 17:30:22 +0000
committerMarinus Schraal <foser@gentoo.org>2003-03-21 17:30:22 +0000
commit40a3a07538c4ee648f8d904e30542c55ddaab420 (patch)
tree65b368729d02ad857cd38b72926ed484f2569d5e /app-office/gnucash
parentAdded hppa to KEYWORDS. (diff)
downloadhistorical-40a3a07538c4ee648f8d904e30542c55ddaab420.tar.gz
historical-40a3a07538c4ee648f8d904e30542c55ddaab420.tar.bz2
historical-40a3a07538c4ee648f8d904e30542c55ddaab420.zip
new version
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.8.21
-rw-r--r--app-office/gnucash/gnucash-1.8.2.ebuild61
3 files changed, 68 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index a422efc91797..47160b87cc89 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.16 2003/03/20 01:00:33 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.17 2003/03/21 17:26:25 foser Exp $
+*gnucash-1.8.2 (21 Mar 2003)
+
+ 21 Mar 2003; foser <foser@gentoo.org> gnucash-1.8.2.ebuild :
+ Fixed SRC_URI and a couple of other minor things
+
*gnucash-1.8.1 (17 Mar 2003)
19 Mar 2003; Jon Nall <nall@gentoo.org> gnucash-1.8.1.ebuild :
diff --git a/app-office/gnucash/files/digest-gnucash-1.8.2 b/app-office/gnucash/files/digest-gnucash-1.8.2
new file mode 100644
index 000000000000..a40fbd473544
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.8.2
@@ -0,0 +1 @@
+MD5 3995f9df6766d2573b1cf96b6b12bea0 gnucash-1.8.2.tar.gz 6555050
diff --git a/app-office/gnucash/gnucash-1.8.2.ebuild b/app-office/gnucash/gnucash-1.8.2.ebuild
new file mode 100644
index 000000000000..25ad0b16c82e
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.8.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.2.ebuild,v 1.1 2003/03/21 17:26:25 foser Exp $
+
+# FIXME - ebuild needs a good look at
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="A personal finance manager"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls postgres"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.3
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2
+ >=gnome-base/gnome-print-0.21
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.3.4
+ <gnome-base/libglade-2
+ media-libs/gdk-pixbuf
+ <dev-util/guile-1.4.1
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+# these flags to GCC interfere with G_INLINE_FUNC usage in this package
+filter-flags "-fno-inline -finline-functions"
+
+src_compile() {
+ elibtoolize
+ local myconf=""
+
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ use postgres \
+ && myconf="${myconf} --enable-sql" \
+ || myconf="${myconf} --disable-sql"
+
+ econf ${myconf}
+
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install() {
+ einstall \
+ pkgdatadir=${D}/usr/share/gnucash
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}