summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2011-03-17 20:48:23 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2011-03-17 20:48:23 +0000
commit010297671428bbe1433db77d0126b41d8decc640 (patch)
treed7c1b007e5918d60da9b2f561a6ac927d54436da /app-office/impressive/impressive-0.10.3.ebuild
parentadd mail-mta/citadel for sunrise (diff)
downloadhistorical-010297671428bbe1433db77d0126b41d8decc640.tar.gz
historical-010297671428bbe1433db77d0126b41d8decc640.tar.bz2
historical-010297671428bbe1433db77d0126b41d8decc640.zip
New application. Thanks to marienz and rafaelmartins for reviewing.
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'app-office/impressive/impressive-0.10.3.ebuild')
-rw-r--r--app-office/impressive/impressive-0.10.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-office/impressive/impressive-0.10.3.ebuild b/app-office/impressive/impressive-0.10.3.ebuild
new file mode 100644
index 000000000000..570f2e40df82
--- /dev/null
+++ b/app-office/impressive/impressive-0.10.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/impressive-0.10.3.ebuild,v 1.1 2011/03/17 20:48:23 dilfridge Exp $
+
+EAPI=3
+PYTHON_DEPEND=2
+
+inherit python
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-text/pdftk
+ dev-python/imaging
+ dev-python/pygame
+ dev-python/pyopengl
+ x11-misc/xdg-utils
+ x11-apps/xrandr
+ || ( app-text/xpdf app-text/ghostscript-gpl )
+ || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera media-fonts/corefonts )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ python_convert_shebangs 2 impressive.py
+ dobin impressive.py || die
+ doman impressive.1 || die
+ dohtml impressive.html || die
+ dodoc changelog.txt demo.pdf || die
+}