summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-01 11:00:42 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-01 11:00:42 +0000
commitb86c32a44fa11c3efc21bd4183f9eb1e370df28e (patch)
tree5d52d405b7360b9e506df4c9027c178345c4e2d4 /app-office/kmymoney2/kmymoney2-0.8.5.ebuild
parentVersion bump. (diff)
downloadhistorical-b86c32a44fa11c3efc21bd4183f9eb1e370df28e.tar.gz
historical-b86c32a44fa11c3efc21bd4183f9eb1e370df28e.tar.bz2
historical-b86c32a44fa11c3efc21bd4183f9eb1e370df28e.zip
Version bump.
Package-Manager: portage-2.1.1_rc1-r2
Diffstat (limited to 'app-office/kmymoney2/kmymoney2-0.8.5.ebuild')
-rw-r--r--app-office/kmymoney2/kmymoney2-0.8.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-office/kmymoney2/kmymoney2-0.8.5.ebuild b/app-office/kmymoney2/kmymoney2-0.8.5.ebuild
new file mode 100644
index 000000000000..9ce7476aa6f9
--- /dev/null
+++ b/app-office/kmymoney2/kmymoney2-0.8.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kmymoney2/kmymoney2-0.8.5.ebuild,v 1.1 2006/09/01 11:00:41 carlo Exp $
+
+inherit kde
+
+DESCRIPTION="Personal Finances Manager for KDE."
+HOMEPAGE="http://kmymoney2.sourceforge.net"
+SRC_URI="mirror://sourceforge/kmymoney2/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt ofx hbci"
+
+DEPEND="dev-libs/libxml2
+ hbci? ( >=net-libs/aqbanking-1.8.0_beta )
+ ofx? ( >=dev-libs/libofx-0.7 )"
+
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/gnupg )"
+
+DEPEND="${DEPEND}
+ dev-util/cppunit"
+
+need-kde 3.4
+
+# TODO: support maketest
+# (needs cppunit in DEPEND)
+
+pkg_setup() {
+ if use hbci && ! built_with_use net-libs/aqbanking kde; then
+ eerror "The HBCI plugin is shipped by net-libs/aqbanking,"
+ eerror "which has to be built with KDE support."
+ die "rebuild net-libs/aqbanking with USE=kde"
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable ofx ofxplugin)
+ $(use_enable hbci kbanking)
+ --disable-cppunit"
+
+ # bug 132665
+ replace-flags "-Os" "-O2"
+
+ kde_src_compile
+}