summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-07 20:30:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-07 20:30:56 +0000
commitb4d4f11c518fef5154660400a6198e8eb28f89ce (patch)
tree746886e893f6888d6ccc8fdf6f3feb4e5aea89dd /app-office/ledger/ledger-2.6.3-r1.ebuild
parentversion bump (bug #350448) (diff)
downloadhistorical-b4d4f11c518fef5154660400a6198e8eb28f89ce.tar.gz
historical-b4d4f11c518fef5154660400a6198e8eb28f89ce.tar.bz2
historical-b4d4f11c518fef5154660400a6198e8eb28f89ce.zip
Revision bump. Add vim-syntax USE flag (bug #369473 by Marek Szuba), update to EAPI 4, update HOMEPAGE, and add static-libs USE flag.
Package-Manager: portage-2.2.0_alpha37/cvs/Linux x86_64
Diffstat (limited to 'app-office/ledger/ledger-2.6.3-r1.ebuild')
-rw-r--r--app-office/ledger/ledger-2.6.3-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-office/ledger/ledger-2.6.3-r1.ebuild b/app-office/ledger/ledger-2.6.3-r1.ebuild
new file mode 100644
index 000000000000..cb2c4d7b0c38
--- /dev/null
+++ b/app-office/ledger/ledger-2.6.3-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/ledger/ledger-2.6.3-r1.ebuild,v 1.1 2011/06/07 20:30:56 radhermit Exp $
+
+EAPI=4
+
+inherit eutils elisp-common autotools
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="http://ledger-cli.org/"
+SRC_URI="http://cloud.github.com/downloads/jwiegley/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+SLOT="0"
+IUSE="emacs debug gnuplot ofx static-libs xml vim-syntax"
+
+DEPEND="dev-libs/gmp
+ dev-libs/libpcre
+ ofx? ( >=dev-libs/libofx-0.9 )
+ xml? ( dev-libs/expat )
+ emacs? ( virtual/emacs )
+ gnuplot? ( sci-visualization/gnuplot )"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+DOCS=(sample.dat README NEWS)
+
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ sed -i -e "/ledger_LDFLAGS/d" Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ # Autodetection of dependencies may fail in the case of:
+ # USE=emacs disabled, app-editors/emacs not installed, app-editors/xemacs installed
+ use emacs || export EMACS=no
+ econf \
+ $(use_enable debug) \
+ $(use_with emacs lispdir "${ED}${SITELISP}/${PN}") \
+ $(use_enable ofx) \
+ $(use_enable static-libs static) \
+ $(use_enable xml)
+}
+
+src_install() {
+ default
+
+ # One script uses vi, the outher the Finance perl module
+ # Did not add more use flags though
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/{entry,getquote,bal,bal-huquq}
+
+ # Remove timeclock since it is part of Emacs
+ rm -f "${ED}${SITELISP}/${PN}"/timeclock.*
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ if use gnuplot; then
+ mv scripts/report ledger-report
+ dobin ledger-report
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ledger.vim
+ fi
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f '{}' +
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}