summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-26 12:22:54 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-26 12:22:54 +0000
commite67a2e7f915573a17224fd8048473dfcb4ec8007 (patch)
tree27fbcbbc027bbc0aaf111e6747074aba0ceb1eda /app-office/magicpoint/magicpoint-1.13a.ebuild
parentversion bump (#301458) (diff)
downloadhistorical-e67a2e7f915573a17224fd8048473dfcb4ec8007.tar.gz
historical-e67a2e7f915573a17224fd8048473dfcb4ec8007.tar.bz2
historical-e67a2e7f915573a17224fd8048473dfcb4ec8007.zip
Respect user flags
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-office/magicpoint/magicpoint-1.13a.ebuild')
-rw-r--r--app-office/magicpoint/magicpoint-1.13a.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-office/magicpoint/magicpoint-1.13a.ebuild b/app-office/magicpoint/magicpoint-1.13a.ebuild
index ebc820f18ea9..043657b6214a 100644
--- a/app-office/magicpoint/magicpoint-1.13a.ebuild
+++ b/app-office/magicpoint/magicpoint-1.13a.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.13a.ebuild,v 1.3 2010/05/26 10:24:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.13a.ebuild,v 1.4 2010/05/26 12:22:54 xarthisius Exp $
-inherit autotools elisp-common eutils fixheadtails
+inherit autotools elisp-common eutils fixheadtails toolchain-funcs
DESCRIPTION="An X11 based presentation tool"
SRC_URI="ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/${P}.tar.gz
@@ -69,7 +69,9 @@ src_compile() {
# no parallel build possibly, anywhere
emake -j1 Makefiles || die "emake Makefiles failed"
emake -j1 clean || die "emake clean failed"
- emake -j1 BINDIR=/usr/bin LIBDIR=/etc/X11 || die "emake failed"
+ tc-export CC
+ emake -j1 CC="${CC}" CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" \
+ BINDIR=/usr/bin LIBDIR=/etc/X11 || die "emake failed"
if use emacs; then
cd contrib/
elisp-compile *.el || die "elisp-compile failed"