summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-07-02 08:12:56 +0000
committerMamoru Komachi <usata@gentoo.org>2005-07-02 08:12:56 +0000
commitabba459cb2491dd7117a5d158ee0ccfb8bb00b06 (patch)
tree8be2f338e7c9c302db0c9e3c5944015ce6088688 /app-office/pybliographer/pybliographer-1.2.6.2.ebuild
parentStable on x86. (diff)
downloadhistorical-abba459cb2491dd7117a5d158ee0ccfb8bb00b06.tar.gz
historical-abba459cb2491dd7117a5d158ee0ccfb8bb00b06.tar.bz2
historical-abba459cb2491dd7117a5d158ee0ccfb8bb00b06.zip
Version bumped; bug #97664.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-office/pybliographer/pybliographer-1.2.6.2.ebuild')
-rw-r--r--app-office/pybliographer/pybliographer-1.2.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/pybliographer/pybliographer-1.2.6.2.ebuild b/app-office/pybliographer/pybliographer-1.2.6.2.ebuild
new file mode 100644
index 000000000000..d167f2891587
--- /dev/null
+++ b/app-office/pybliographer/pybliographer-1.2.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/pybliographer-1.2.6.2.ebuild,v 1.1 2005/07/02 08:12:56 usata Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Pybliographer is a tool for working with bibliographic databases"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE=""
+
+# gnome2.eclass
+USE_DESTDIR=1
+DOCS="AUTHORS COPYING ChangeLog* INSTALL NEWS TODO README"
+
+DEPEND="virtual/python
+ >=dev-libs/glib-2
+ >=app-text/recode-3.6-r1
+ >=dev-python/gnome-python-2
+ >=dev-python/python-bibtex-1.2.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.2.4-gentoo.diff
+}
+
+src_install() {
+ # fix for access violation due to eclass change
+ gnome2_src_install scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/
+}