summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-06 19:33:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-06 19:33:29 +0000
commitb02d6193efd5cbbdf80955f78b86287ec936a331 (patch)
tree1ac231ef87bed68abc38ceddcae2234b6c1999a6 /app-office/scribus/files
parentadd libglade dependency from Prefix (diff)
downloadhistorical-b02d6193efd5cbbdf80955f78b86287ec936a331.tar.gz
historical-b02d6193efd5cbbdf80955f78b86287ec936a331.tar.bz2
historical-b02d6193efd5cbbdf80955f78b86287ec936a331.zip
Version bump.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'app-office/scribus/files')
-rw-r--r--app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch26
-rw-r--r--app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch21
-rw-r--r--app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch105
3 files changed, 152 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch b/app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch
new file mode 100644
index 000000000000..40c93226138e
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.3.5.1-check-hdict.patch
@@ -0,0 +1,26 @@
+From dedea3f94802f0f9d9adef4c48f8061282baf776 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
+Date: Mon, 23 Nov 2009 10:13:48 +0100
+Subject: [PATCH] check hdict value before freeing the hyphenator
+
+---
+ Scribus/scribus/hyphenator.cpp | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/Scribus/scribus/hyphenator.cpp b/Scribus/scribus/hyphenator.cpp
+index 614db47..4da4467 100644
+--- a/Scribus/scribus/hyphenator.cpp
++++ b/Scribus/scribus/hyphenator.cpp
+@@ -90,7 +90,8 @@ Hyphenator::Hyphenator(QWidget* parent, ScribusDoc *dok) : QObject( parent ),
+
+ Hyphenator::~Hyphenator()
+ {
+- hnj_hyphen_free(hdict);
++ if (hdict)
++ hnj_hyphen_free(hdict);
+ }
+
+ void Hyphenator::NewDict(const QString& name)
+--
+1.6.3.3
+
diff --git a/app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch b/app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch
new file mode 100644
index 000000000000..6b7492770359
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.3.5.1-lib2geom.patch
@@ -0,0 +1,21 @@
+diff -ur scribus-1.3.5.1.orig/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt scribus-1.3.5.1/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt
+--- scribus-1.3.5.1.orig/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt 2008-06-02 01:38:43.000000000 +0300
++++ scribus-1.3.5.1/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt 2010-01-06 20:31:13.000000000 +0200
+@@ -16,6 +16,10 @@
+ #CB SET(CMAKE_MAKE_PROGRAM "${CMAKE_MAKE_PROGRAM}")
+ # We need to pass -fPIC only to lib2geom on amd64 - avoid it elsewhere see: http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3
+
++IF (ARCH_X86_64 EQUAL 1)
++ SET(CMAKE_CXX_FLAGS "$(CMAKE_CXX_FLAGS) -fPIC")
++ENDIF (ARCH_X86_64 EQUAL 1)
++
+ OPTION(2GEOM_BUILD_SHARED
+ "Build lib2geom and libtoy as shared libraries."
+ OFF)
+@@ -112,4 +116,4 @@
+ #CONFIGURE_FILE( ${CMAKE_SOURCE_DIR}/2geom.pc.in
+ # ${CMAKE_BINARY_DIR}/2geom.pc @ONLY IMMEDIATE )
+ #INSTALL(FILES "${CMAKE_BINARY_DIR}/2geom.pc" DESTINATION lib/pkgconfig)
+-#
+\ No newline at end of file
++#
diff --git a/app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch b/app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch
new file mode 100644
index 000000000000..2884cdde1565
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.3.5.1-system-hyphen.patch
@@ -0,0 +1,105 @@
+diff -Nrup scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake scribus-1.3.5.rc3/cmake/modules/FindHYPHEN.cmake
+--- scribus-1.3.5.rc3.orig/cmake/modules/FindHYPHEN.cmake 1970-01-01 01:00:00.000000000 +0100
++++ scribus-1.3.5.rc3/cmake/modules/FindHYPHEN.cmake 2009-07-02 14:23:26.000000000 +0200
+@@ -0,0 +1,28 @@
++# - Find HYPHEN library
++# Find the native HYPHEN includes and library
++# This module defines
++# HYPHEN_INCLUDE_DIR, where to find hyphen.h, etc.
++# HYPHEN_LIBRARIES, libraries to link against to use HYPHEN.
++# HYPHEN_FOUND, If false, do not try to use HYPHEN.
++# also defined, but not for general use are
++# HYPHEN_LIBRARY, where to find the HYPHEN library.
++
++FIND_PATH(HYPHEN_INCLUDE_DIR hyphen.h)
++
++SET(HYPHEN_NAMES_RELEASE ${HYPHEN_NAMES_RELEASE} ${HYPHEN_NAMES} hyphen libhyphen)
++SET(HYPHEN_NAMES_DEBUG ${HYPHEN_NAMES_DEBUG} hyphend libhyphend)
++
++FIND_LIBRARY(HYPHEN_LIBRARY_RELEASE NAMES ${HYPHEN_NAMES_RELEASE} )
++FIND_LIBRARY(HYPHEN_LIBRARY_DEBUG NAMES ${HYPHEN_NAMES_DEBUG} )
++
++INCLUDE(LibraryDebugAndRelease)
++SET_LIBRARY_FROM_DEBUG_AND_RELEASE(HYPHEN)
++
++# handle the QUIETLY and REQUIRED arguments and set HYPHEN_FOUND to TRUE if
++# all listed variables are TRUE
++INCLUDE(ScribusFindPackageHandleStandardArgs)
++FIND_PACKAGE_HANDLE_STANDARD_ARGS(HYPHEN DEFAULT_MSG HYPHEN_LIBRARY HYPHEN_INCLUDE_DIR)
++
++IF(HYPHEN_FOUND)
++ SET( HYPHEN_LIBRARIES ${HYPHEN_LIBRARY} )
++ENDIF(HYPHEN_FOUND)
+--- scribus-1.3.5.rc3.orig/CMakeLists.txt 2009-05-30 14:38:09.000000000 +0200
++++ scribus-1.3.5.rc3/CMakeLists.txt 2009-07-02 14:32:24.000000000 +0200
+@@ -638,6 +638,16 @@ ELSE(LIBPODOFO_FOUND)
+ ENDIF(LIBPODOFO_FOUND)
+ #>>PoDoFo for AI PDF import
+
++#<<HYPHEN for system hyphenation library
++FIND_PACKAGE(HYPHEN)
++IF(HYPHEN_FOUND)
++ MESSAGE("system hyphenation library found OK")
++ SET(HAVE_HYPHEN 1)
++ELSE(HYPHEN_FOUND)
++ MESSAGE("system hyphenation library NOT found - will use internal one")
++ENDIF(HYPHEN_FOUND)
++#>>HYPHEN for system hyphenation library
++
+ ##############################################################################################################
+ ########## Include Setup ##########
+
+diff -Nrup -x CMakeFiles -x Makefile -x FindHYPHEN.cmake scribus-1.3.5.rc3.orig/scribus/CMakeLists.txt scribus-1.3.5.rc3/scribus/CMakeLists.txt
+--- scribus-1.3.5.rc3.orig/scribus/CMakeLists.txt 2009-06-07 09:05:54.000000000 +0200
++++ scribus-1.3.5.rc3/scribus/CMakeLists.txt 2009-07-02 15:22:52.000000000 +0200
+@@ -403,10 +403,8 @@ SET(SCRIBUS_SOURCES
+ guidesdelegate.cpp
+ guidesmodel.cpp
+ helpbrowser.cpp
+- hnjalloc.c
+ hruler.cpp
+ hyask.cpp
+- hyphen.c
+ hyphenator.cpp
+ hysettings.cpp
+ imageinfodialog.cpp
+@@ -641,6 +639,14 @@ SET(SCRIBUS_SOURCES
+ vruler.cpp
+ )
+
++IF(NOT HAVE_HYPHEN)
++ SET(SCRIBUS_SOURCES
++ ${SCRIBUS_SOURCES}
++ hnjalloc.c
++ hyphen.c
++ )
++ENDIF(NOT HAVE_HYPHEN)
++
+ IF(WIN32)
+ SET(SCRIBUS_MOC_WIN32_ONLY_CLASSES scprintengine_gdi.h)
+ SET(SCRIBUS_WIN32_ONLY_SOURCES
+@@ -785,6 +791,12 @@ IF(HAVE_PODOFO)
+ )
+ ENDIF(HAVE_PODOFO)
+
++IF(HAVE_HYPHEN)
++ TARGET_LINK_LIBRARIES(${EXE_NAME}
++ ${HYPHEN_LIBRARY}
++ )
++ENDIF(HAVE_HYPHEN)
++
+ # Now build plugins
+ SET(PLUGIN_LIBRARIES)
+ IF(WIN32)
+diff -Nrup -x CMakeFiles -x Makefile -x '*.cmake' scribus-1.3.5.rc3.orig/scribus/hyphenator.h scribus-1.3.5.rc3/scribus/hyphenator.h
+--- scribus-1.3.5.rc3.orig/scribus/hyphenator.h 2007-07-10 22:33:09.000000000 +0200
++++ scribus-1.3.5.rc3/scribus/hyphenator.h 2009-07-02 14:03:11.000000000 +0200
+@@ -13,7 +13,7 @@ for which a new license (GPL+exception)
+ #include <QSet>
+
+ #include "scribusapi.h"
+-#include "hyphen.h"
++#include <hyphen.h>
+ class ScribusDoc;
+ class ScribusMainWindow;
+ class PageItem;