summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-04 09:11:02 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-04 09:11:02 +0000
commite8ba3e0254bd9da2b61892b2625ac1b1e1831be1 (patch)
tree7ce5d242c67e5c6f7fd721a1d7a2e9e5d152c9ac /app-office/scribus/scribus-1.3.6.ebuild
parentRemove old. (diff)
downloadhistorical-e8ba3e0254bd9da2b61892b2625ac1b1e1831be1.tar.gz
historical-e8ba3e0254bd9da2b61892b2625ac1b1e1831be1.tar.bz2
historical-e8ba3e0254bd9da2b61892b2625ac1b1e1831be1.zip
Version Bump, added linguas support, #315567; cleaned old
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'app-office/scribus/scribus-1.3.6.ebuild')
-rw-r--r--app-office/scribus/scribus-1.3.6.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/app-office/scribus/scribus-1.3.6.ebuild b/app-office/scribus/scribus-1.3.6.ebuild
deleted file mode 100644
index 565ccba3b644..000000000000
--- a/app-office/scribus/scribus-1.3.6.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.3.6.ebuild,v 1.12 2011/11/17 17:05:54 jlec Exp $
-
-EAPI=2
-
-PYTHON_DEPEND="2:2.6"
-
-inherit cmake-utils fdo-mime multilib python
-
-DESCRIPTION="Desktop publishing (DTP) and layout program"
-HOMEPAGE="http://www.scribus.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 ~sparc x86"
-IUSE="cairo debug +minimal +pdf spell"
-
-COMMON_DEPEND="
- dev-libs/hyphen
- dev-libs/libxml2
- media-libs/fontconfig
- media-libs/freetype:2
- media-libs/lcms:0
- media-libs/libpng:0
- media-libs/tiff:0
- net-print/cups
- sys-libs/zlib
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- virtual/jpeg
- spell? ( app-text/aspell )
- pdf? ( app-text/podofo )
- cairo? ( x11-libs/cairo[X,svg] )"
-RDEPEND="${COMMON_DEPEND}
- app-text/ghostscript-gpl"
-DEPEND="${COMMON_DEPEND}
- dev-libs/boost"
-
-RESTRICT="mirror" #318643
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.5.1-system-hyphen.patch"
- "${FILESDIR}/${PN}-1.3.6-podofo-0.8.0.patch"
- )
-
-DOCS="AUTHORS ChangeLog* LINKS NEWS README TODO TRANSLATION"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_configure() {
- mycmakeargs=(
- "-DHAVE_PYTHON=ON"
- "-DPYTHON_INCLUDE_PATH=$(python_get_includedir)"
- "-DPYTHON_LIBRARY=$(python_get_library)"
- "-DWANT_NORPATH=ON"
- "-DWANT_QTARTHUR=ON"
- "-DWANT_QT3SUPPORT=OFF"
- $(cmake-utils_use_has spell ASPELL)
- $(cmake-utils_use_has pdf PODOFO)
- $(cmake-utils_use_want cairo)
- $(cmake-utils_use_want minimal NOHEADERINSTALL)
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- doicon resources/icons/scribus.png
- domenu scribus.desktop
-}
-
-pkg_postinst() {
- fdo-mime_mime_database_update
-}
-
-pkg_postrm() {
- fdo-mime_mime_database_update
-}