summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-26 09:48:24 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-26 09:48:24 +0000
commitba75e9e53ff9874805d90b88b878c93d04064204 (patch)
tree64895547532dfae4205f739b9c55efab7dcc10c6 /app-office/texmaker/texmaker-3.5.ebuild
parentnet-analyzer/linkchecker: Drop old (diff)
downloadhistorical-ba75e9e53ff9874805d90b88b878c93d04064204.tar.gz
historical-ba75e9e53ff9874805d90b88b878c93d04064204.tar.bz2
historical-ba75e9e53ff9874805d90b88b878c93d04064204.zip
app-office/texmaker: Version BUmp; #432476
Package-Manager: portage-2.2.0_alpha122/cvs/Linux x86_64
Diffstat (limited to 'app-office/texmaker/texmaker-3.5.ebuild')
-rw-r--r--app-office/texmaker/texmaker-3.5.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-office/texmaker/texmaker-3.5.ebuild b/app-office/texmaker/texmaker-3.5.ebuild
new file mode 100644
index 000000000000..d41c238e8f24
--- /dev/null
+++ b/app-office/texmaker/texmaker-3.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.5.ebuild,v 1.1 2012/08/26 09:48:24 jlec Exp $
+
+EAPI=4
+
+inherit base qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/qt-webkit:4
+ app-text/hunspell"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hunspell.patch
+ "${FILESDIR}"/${PN}-3.3.3-qt48.patch
+ )
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png
+ doins utilities/texmaker.svg
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}