summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2005-12-07 14:06:36 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2005-12-07 14:06:36 +0000
commit88959f902adc6fbad0e4554097160ed62b22a794 (patch)
tree3e08ced29c6a9aac33f36c7608a1a5c0ed9e62a9 /app-office/texmaker
parentNew snapshot (diff)
downloadhistorical-88959f902adc6fbad0e4554097160ed62b22a794.tar.gz
historical-88959f902adc6fbad0e4554097160ed62b22a794.tar.bz2
historical-88959f902adc6fbad0e4554097160ed62b22a794.zip
Bump to 1.2.1, that uses qt4.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog9
-rw-r--r--app-office/texmaker/Manifest6
-rw-r--r--app-office/texmaker/files/digest-texmaker-1.2.11
-rw-r--r--app-office/texmaker/texmaker-1.2.1.ebuild51
4 files changed, 64 insertions, 3 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index d2f76aad86b3..eb8e02c53cc5 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.8 2005/07/02 08:58:14 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.9 2005/12/07 14:06:36 nattfodd Exp $
+
+*texmaker-1.2.1 (07 Dec 2005)
+
+ 07 Dec 2005; Alexandre Buisse <nattfodd@gentoo.org>
+ +texmaker-1.2.1.ebuild:
+ Bump to 1.2.1 (mainly switch to qt4). Thanks to Markus Ullmann for the ebuild
+ (bug #114037).
*texmaker-1.11-r1 (02 Jul 2005)
diff --git a/app-office/texmaker/Manifest b/app-office/texmaker/Manifest
index 421251825d3d..b40ccba93009 100644
--- a/app-office/texmaker/Manifest
+++ b/app-office/texmaker/Manifest
@@ -1,6 +1,8 @@
-MD5 0f066587d60dbdf5769790c3191e57e6 ChangeLog 1142
-MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 4795d01e61e250245aef7dfeabff2d9a texmaker-1.11.ebuild 1395
MD5 b6d6970bed253b1b6426c1d64a01c91f texmaker-1.11-r1.ebuild 1499
+MD5 5e36b2f072b368199d7d6ea5059ecc5a texmaker-1.2.1.ebuild 1259
+MD5 7fa34b2d861b2596cb6c2cf4a428b521 ChangeLog 1354
+MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 6523b9d37f10392c4198cac68935cd93 files/digest-texmaker-1.11 66
+MD5 87c6b930962d1f18ddef65c23a1ccd79 files/digest-texmaker-1.2.1 67
MD5 6523b9d37f10392c4198cac68935cd93 files/digest-texmaker-1.11-r1 66
diff --git a/app-office/texmaker/files/digest-texmaker-1.2.1 b/app-office/texmaker/files/digest-texmaker-1.2.1
new file mode 100644
index 000000000000..c6fa6d9e2955
--- /dev/null
+++ b/app-office/texmaker/files/digest-texmaker-1.2.1
@@ -0,0 +1 @@
+MD5 5c7386b89155e973d506ecc6319d129f texmaker-1.2.1.tar.bz2 774811
diff --git a/app-office/texmaker/texmaker-1.2.1.ebuild b/app-office/texmaker/texmaker-1.2.1.ebuild
new file mode 100644
index 000000000000..5e4e013e7e6f
--- /dev/null
+++ b/app-office/texmaker/texmaker-1.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-1.2.1.ebuild,v 1.1 2005/12/07 14:06:36 nattfodd Exp $
+
+inherit qt4 eutils
+
+DESCRIPTION="a nice LaTeX-IDE"
+
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/tetex
+ app-text/psutils
+ virtual/ghostscript
+ media-libs/netpbm
+ $(qt_min_version 4)"
+
+src_compile() {
+ cd ${S}
+ qmake -unix texmaker.pro || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin texmaker || die "doexe failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+
+ dodoc utilities/{AUTHORS,COPYING} || die "dodoc failed"
+
+ dohtml utilities/*.{html,gif,css,txt} utilities/doc*.png || die "dohtml failed"
+
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN} || die "dosym failed"
+
+ make_desktop_entry texmaker Texmaker "/usr/share/pixmaps/texmaker/texmaker48x48.png" Office
+}
+
+pkg_postinst() {
+ einfo "A user manual with many screenshots is available at:"
+ einfo "/usr/share/doc/${PF}/html/usermanual.html"
+}