summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-06-22 13:21:47 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-06-22 13:21:47 +0000
commit54d4f0db7fd05d0427b8da35a1586fec1e31f704 (patch)
tree59c5ccf26673b9214c1b9a4ab482409eefb179d1 /app-office
parentStable on sparc (diff)
downloadhistorical-54d4f0db7fd05d0427b8da35a1586fec1e31f704.tar.gz
historical-54d4f0db7fd05d0427b8da35a1586fec1e31f704.tar.bz2
historical-54d4f0db7fd05d0427b8da35a1586fec1e31f704.zip
Add patch to fix critical problem when saving from koshell.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice-libs/ChangeLog8
-rw-r--r--app-office/koffice-libs/files/digest-koffice-libs-1.4.0-r11
-rw-r--r--app-office/koffice-libs/files/koffice-1.4.0-save.patch15
-rw-r--r--app-office/koffice-libs/koffice-libs-1.4.0-r1.ebuild65
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.4.0-r11
-rw-r--r--app-office/koffice/files/koffice-1.4.0-save.patch15
-rw-r--r--app-office/koffice/koffice-1.4.0-r1.ebuild70
-rw-r--r--app-office/koffice/koffice-1.4.0.ebuild4
-rw-r--r--app-office/koffice/koffice-1.4.0_rc1.ebuild4
10 files changed, 185 insertions, 6 deletions
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index 5f036efa1370..9ba617823e98 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for app-office/koffice-libs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.8 2005/06/22 12:46:41 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.9 2005/06/22 13:21:47 greg_g Exp $
22 Jun 2005; Markus Rothe <corsair@gentoo.org> koffice-libs-1.3.5.ebuild,
koffice-libs-1.4.0.ebuild:
Added ~ppc64
+*koffice-libs-1.4.0-r1 (22 Jun 2005)
+
+ 22 Jun 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/koffice-1.4.0-save.patch, +koffice-libs-1.4.0-r1.ebuild:
+ Add patch to fix critical problem when saving from koshell.
+
*koffice-libs-1.4.0 (21 Jun 2005)
21 Jun 2005; Gregorio Guidi <greg_g@gentoo.org>
diff --git a/app-office/koffice-libs/files/digest-koffice-libs-1.4.0-r1 b/app-office/koffice-libs/files/digest-koffice-libs-1.4.0-r1
new file mode 100644
index 000000000000..aada0edc41ee
--- /dev/null
+++ b/app-office/koffice-libs/files/digest-koffice-libs-1.4.0-r1
@@ -0,0 +1 @@
+MD5 3e6fd9f92024de68e5879c22d02a33c5 koffice-1.4.0.tar.bz2 19730186
diff --git a/app-office/koffice-libs/files/koffice-1.4.0-save.patch b/app-office/koffice-libs/files/koffice-1.4.0-save.patch
new file mode 100644
index 000000000000..40772ef93525
--- /dev/null
+++ b/app-office/koffice-libs/files/koffice-1.4.0-save.patch
@@ -0,0 +1,15 @@
+diff -Nur koffice-1.4.0.orig/lib/kofficecore/koDocument.cc koffice-1.4.0/lib/kofficecore/koDocument.cc
+--- koffice-1.4.0.orig/lib/kofficecore/koDocument.cc 2005-06-15 15:39:33.000000000 +0200
++++ koffice-1.4.0/lib/kofficecore/koDocument.cc 2005-06-22 14:58:03.000000000 +0200
+@@ -354,11 +354,6 @@
+ bool KoDocument::saveFile()
+ {
+ kdDebug(30003) << "KoDocument::saveFile() doc='" << url().url() <<"'"<< endl;
+- if ( !kapp->inherits( "KoApplication" ) )
+- {
+- d->lastErrorMessage = i18n( "Internal error: not a KOffice application, saving not allowed." );
+- return false;
+- }
+
+ // Save it to be able to restore it after a failed save
+ const bool wasModified = isModified ();
diff --git a/app-office/koffice-libs/koffice-libs-1.4.0-r1.ebuild b/app-office/koffice-libs/koffice-libs-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..63a5dfda7886
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-1.4.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-1.4.0-r1.ebuild,v 1.1 2005/06/22 13:21:47 greg_g Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+KMMODULE=lib
+inherit kde-meta eutils
+
+DESCRIPTION="Shared KOffice libraries."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~amd64"
+IUSE="doc"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-data)"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+KMEXTRA="
+ interfaces/
+ plugins/
+ tools/
+ filters/olefilters/
+ filters/xsltfilter/
+ filters/generic_wrapper/
+ kounavail/
+ doc/api/
+ doc/koffice/
+ doc/thesaurus/"
+
+KMEXTRACTONLY="
+ kchart/kdchart/"
+
+need-kde 3.3
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # Fix problem when saving from koshell. Applied for 1.4.1.
+ epatch "${FILESDIR}/koffice-1.4.0-save.patch"
+
+ # Force the compilation of libkopainter.
+ sed -i 's:$(KOPAINTERDIR):kopainter:' $S/lib/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}
+
+src_compile() {
+ kde-meta_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde-meta_src_install
+ if use doc; then
+ make DESTDIR=${D} install-apidox || die
+ fi
+}
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 08486acb39ea..12c0d333b992 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.102 2005/06/21 08:36:41 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.103 2005/06/22 13:19:08 greg_g Exp $
+
+*koffice-1.4.0-r1 (22 Jun 2005)
+
+ 22 Jun 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/koffice-1.4.0-save.patch, +koffice-1.4.0-r1.ebuild:
+ Add patch to fix critical problem when saving from koshell.
*koffice-1.4.0 (21 Jun 2005)
diff --git a/app-office/koffice/files/digest-koffice-1.4.0-r1 b/app-office/koffice/files/digest-koffice-1.4.0-r1
new file mode 100644
index 000000000000..aada0edc41ee
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.4.0-r1
@@ -0,0 +1 @@
+MD5 3e6fd9f92024de68e5879c22d02a33c5 koffice-1.4.0.tar.bz2 19730186
diff --git a/app-office/koffice/files/koffice-1.4.0-save.patch b/app-office/koffice/files/koffice-1.4.0-save.patch
new file mode 100644
index 000000000000..40772ef93525
--- /dev/null
+++ b/app-office/koffice/files/koffice-1.4.0-save.patch
@@ -0,0 +1,15 @@
+diff -Nur koffice-1.4.0.orig/lib/kofficecore/koDocument.cc koffice-1.4.0/lib/kofficecore/koDocument.cc
+--- koffice-1.4.0.orig/lib/kofficecore/koDocument.cc 2005-06-15 15:39:33.000000000 +0200
++++ koffice-1.4.0/lib/kofficecore/koDocument.cc 2005-06-22 14:58:03.000000000 +0200
+@@ -354,11 +354,6 @@
+ bool KoDocument::saveFile()
+ {
+ kdDebug(30003) << "KoDocument::saveFile() doc='" << url().url() <<"'"<< endl;
+- if ( !kapp->inherits( "KoApplication" ) )
+- {
+- d->lastErrorMessage = i18n( "Internal error: not a KOffice application, saving not allowed." );
+- return false;
+- }
+
+ // Save it to be able to restore it after a failed save
+ const bool wasModified = isModified ();
diff --git a/app-office/koffice/koffice-1.4.0-r1.ebuild b/app-office/koffice/koffice-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..0c934c122203
--- /dev/null
+++ b/app-office/koffice/koffice-1.4.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.4.0-r1.ebuild,v 1.1 2005/06/22 13:19:08 greg_g Exp $
+
+inherit kde eutils
+
+DESCRIPTION="An integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/koffice-1.4/src/${P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc javascript mysql postgres"
+
+RDEPEND=">=media-gfx/imagemagick-5.5.2
+ >=app-text/wv2-0.1.9
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ dev-lang/python
+ media-libs/lcms
+ javascript? ( kde-base/kjsembed )
+ !dev-db/kexi"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.3
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix problem when saving from koshell. Applied for 1.4.1.
+ epatch "${FILESDIR}/${P}-save.patch"
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}
diff --git a/app-office/koffice/koffice-1.4.0.ebuild b/app-office/koffice/koffice-1.4.0.ebuild
index 1c4d1fb4a09f..f66a98fbdfc7 100644
--- a/app-office/koffice/koffice-1.4.0.ebuild
+++ b/app-office/koffice/koffice-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.4.0.ebuild,v 1.1 2005/06/21 08:36:41 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.4.0.ebuild,v 1.2 2005/06/22 13:19:08 greg_g Exp $
inherit kde eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://kde/stable/koffice-1.4/src/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc javascript mysql postgres"
RDEPEND=">=media-gfx/imagemagick-5.5.2
diff --git a/app-office/koffice/koffice-1.4.0_rc1.ebuild b/app-office/koffice/koffice-1.4.0_rc1.ebuild
index c025c1bcae0e..91ef2da476ea 100644
--- a/app-office/koffice/koffice-1.4.0_rc1.ebuild
+++ b/app-office/koffice/koffice-1.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.4.0_rc1.ebuild,v 1.4 2005/06/11 09:55:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.4.0_rc1.ebuild,v 1.5 2005/06/22 13:19:08 greg_g Exp $
inherit kde eutils
@@ -13,7 +13,7 @@ SRC_URI="mirror://kde/unstable/koffice-1.4-rc1/src/koffice-${MY_PV}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc javascript mysql postgres"
RDEPEND=">=media-gfx/imagemagick-5.5.2