summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-12-30 21:57:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-12-30 21:57:36 +0000
commit675791136a1aa9656b056613495ea85699445c05 (patch)
tree0b24301b74e9bc0c5e001f3eeb6012536fe567cf /app-office
parentChange encoding to UTF-8 for GLEP 31 compliance (diff)
downloadhistorical-675791136a1aa9656b056613495ea85699445c05.tar.gz
historical-675791136a1aa9656b056613495ea85699445c05.tar.bz2
historical-675791136a1aa9656b056613495ea85699445c05.zip
added a check for whether bitmap-fonts support exists in xorg-x11. Closes bug #75910 by Volkov Peter <torre_cremata@mail.ru>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/Manifest8
-rw-r--r--app-office/gnucash/gnucash-1.8.10.ebuild15
-rw-r--r--app-office/gnucash/gnucash-1.8.8.ebuild16
-rw-r--r--app-office/gnucash/gnucash-1.8.9.ebuild15
5 files changed, 53 insertions, 8 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 84e23795de20..13d870094f09 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.57 2004/12/30 20:56:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.58 2004/12/30 21:57:36 seemant Exp $
+
+ 30 Dec 2004; Seemant Kulleen <seemant@gentoo.org> gnucash-1.8.10.ebuild,
+ gnucash-1.8.8.ebuild, gnucash-1.8.9.ebuild:
+ added a check for whether bitmap-fonts support exists in xorg-x11. Closes
+ bug #75910 by Volkov Peter <torre_cremata@mail.ru>
30 Dec 2004; Seemant Kulleen <seemant@gentoo.org> gnucash-1.8.10.ebuild:
changed hbci dependency from aqhbci to aqhbci-wizard-kde, closing bug #75961
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
index 1599d5c64643..e2600c6d1b41 100644
--- a/app-office/gnucash/Manifest
+++ b/app-office/gnucash/Manifest
@@ -1,8 +1,8 @@
-MD5 0bf44bac53f6bfeb5d86200bb05b1a8a gnucash-1.8.9.ebuild 3079
-MD5 59bb70d7218deaddab7762041975c615 gnucash-1.8.10.ebuild 3102
-MD5 a79bb7726f744e666acf38fc7b069104 ChangeLog 9595
+MD5 f07e7ad03203ebb0fd9adb0d3cdd5bd4 gnucash-1.8.9.ebuild 3497
+MD5 bf6ebd9186b8b22c708ad494ddb98bbf gnucash-1.8.10.ebuild 3520
+MD5 7c0ce14aefb62c15fa646d780dfc78de ChangeLog 9846
MD5 3c20dccad7b705d7e9a379e6831149f9 metadata.xml 252
-MD5 344fd6f2a055d6db85a178b6b124851e gnucash-1.8.8.ebuild 2644
+MD5 32189e556873810d709b34454596dd5e gnucash-1.8.8.ebuild 3064
MD5 e7f62a929b825e039b0912ade52c5998 files/digest-gnucash-1.8.8 137
MD5 6f6c233c0f0e5d8115b1fccc1ae3e3c0 files/digest-gnucash-1.8.9 137
MD5 cda4007bfba409e082e55b854576d97f files/digest-gnucash-1.8.10 138
diff --git a/app-office/gnucash/gnucash-1.8.10.ebuild b/app-office/gnucash/gnucash-1.8.10.ebuild
index caf2895e34e6..f456ca777463 100644
--- a/app-office/gnucash/gnucash-1.8.10.ebuild
+++ b/app-office/gnucash/gnucash-1.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.10.ebuild,v 1.5 2004/12/30 20:56:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.10.ebuild,v 1.6 2004/12/30 21:57:36 seemant Exp $
inherit flag-o-matic libtool eutils
@@ -60,6 +60,19 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if built_with_use xorg-x11 bitmap-fonts
+ then
+ einfo "bitmap-fonts support is enabled in xorg-x11, continuing..."
+ else
+ eerror "Please rebuild xorg-x11 with bitmap font support!"
+ eerror "To do so: USE=\"bitmap-fonts\" emerge xorg-x11"
+ eerror "Or, add \"bitmap-fonts\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Will not build gnucash without bitmap-fonts support in xorg-x11"
+ fi
+}
+
src_compile() {
elibtoolize
diff --git a/app-office/gnucash/gnucash-1.8.8.ebuild b/app-office/gnucash/gnucash-1.8.8.ebuild
index 9bb0ce1f1d04..9475a78aeff2 100644
--- a/app-office/gnucash/gnucash-1.8.8.ebuild
+++ b/app-office/gnucash/gnucash-1.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.8.ebuild,v 1.9 2004/10/18 07:13:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.8.ebuild,v 1.10 2004/12/30 21:57:36 seemant Exp $
inherit flag-o-matic libtool
@@ -54,6 +54,20 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ if built_with_use xorg-x11 bitmap-fonts
+ then
+ einfo "bitmap-fonts support is enabled in xorg-x11, continuing..."
+ else
+ eerror "Please rebuild xorg-x11 with bitmap font support!"
+ eerror "To do so: USE=\"bitmap-fonts\" emerge xorg-x11"
+ eerror "Or, add \"bitmap-fonts\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Will not build gnucash without bitmap-fonts support in xorg-x11"
+ fi
+}
+
src_compile() {
elibtoolize
local myconf=""
diff --git a/app-office/gnucash/gnucash-1.8.9.ebuild b/app-office/gnucash/gnucash-1.8.9.ebuild
index 9be4d4b46f71..b2165a1445da 100644
--- a/app-office/gnucash/gnucash-1.8.9.ebuild
+++ b/app-office/gnucash/gnucash-1.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.9.ebuild,v 1.11 2004/12/26 17:52:30 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.9.ebuild,v 1.12 2004/12/30 21:57:36 seemant Exp $
inherit flag-o-matic libtool eutils
@@ -59,6 +59,19 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if built_with_use xorg-x11 bitmap-fonts
+ then
+ einfo "bitmap-fonts support is enabled in xorg-x11, continuing..."
+ else
+ eerror "Please rebuild xorg-x11 with bitmap font support!"
+ eerror "To do so: USE=\"bitmap-fonts\" emerge xorg-x11"
+ eerror "Or, add \"bitmap-fonts\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Will not build gnucash without bitmap-fonts support in xorg-x11"
+ fi
+}
+
src_compile() {
elibtoolize