summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-09-24 06:46:13 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-09-24 06:46:13 +0000
commit8095d92cf5e5df9e8a54f8f4593a450470737947 (patch)
tree3e62044ef22643b6e9cb0a42b3f46303821efce9 /app-office
parentold (diff)
downloadhistorical-8095d92cf5e5df9e8a54f8f4593a450470737947.tar.gz
historical-8095d92cf5e5df9e8a54f8f4593a450470737947.tar.bz2
historical-8095d92cf5e5df9e8a54f8f4593a450470737947.zip
Fix icons to correctly display for both openoffice and openoffice-ximian,
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'app-office')
-rw-r--r--app-office/oooqs/ChangeLog6
-rw-r--r--app-office/oooqs/Manifest10
-rw-r--r--app-office/oooqs/files/fixxooo.patch71
3 files changed, 72 insertions, 15 deletions
diff --git a/app-office/oooqs/ChangeLog b/app-office/oooqs/ChangeLog
index a726d424537e..6029ab0c8da2 100644
--- a/app-office/oooqs/ChangeLog
+++ b/app-office/oooqs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/oooqs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.16 2005/04/24 11:28:22 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.17 2005/09/24 06:46:13 suka Exp $
+
+ 24 Sep 2005; Andreas Proschofsky <suka@gentoo.org> files/fixxooo.patch:
+ Fix icons to correctly display for both openoffice and openoffice-ximian,
+ closes bug #94857
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> oooqs-2.0.3.ebuild:
Stable on ppc.
diff --git a/app-office/oooqs/Manifest b/app-office/oooqs/Manifest
index d8f6820c6bf2..9c466c328ac4 100644
--- a/app-office/oooqs/Manifest
+++ b/app-office/oooqs/Manifest
@@ -1,9 +1,9 @@
-MD5 1b4a6eb83c4267e11b9089d34206029b oooqs-2.0.3.ebuild 664
-MD5 d89f6d524fdd9cce162c5959fa9fed1b metadata.xml 269
-MD5 5842322eb3b8c7fc86d7701d5b7a7107 ChangeLog 1802
MD5 13a0a7ca0b9e838095dfe91d6e812834 oooqs-2.0.2.ebuild 651
+MD5 1b4a6eb83c4267e11b9089d34206029b oooqs-2.0.3.ebuild 664
MD5 f3855b265eefcd0fa1f90489b077cf74 oooqs-2.0.3-r1.ebuild 971
+MD5 bf9aa29ca91388e3c3be35c3c65ae81c ChangeLog 1971
+MD5 d89f6d524fdd9cce162c5959fa9fed1b metadata.xml 269
MD5 0dfa431673ed5292d63d41d5ca44bebc files/digest-oooqs-2.0.2 63
-MD5 b96223d4f6f3f644e5a345c12982ab72 files/digest-oooqs-2.0.3-r1 63
MD5 b96223d4f6f3f644e5a345c12982ab72 files/digest-oooqs-2.0.3 63
-MD5 21f765f87dd345ef6ff0b2dfa632dd7a files/fixxooo.patch 890
+MD5 b96223d4f6f3f644e5a345c12982ab72 files/digest-oooqs-2.0.3-r1 63
+MD5 d5a62d4399d509af355598951028ec8f files/fixxooo.patch 3350
diff --git a/app-office/oooqs/files/fixxooo.patch b/app-office/oooqs/files/fixxooo.patch
index c3afe7a9d528..a1c2d609b14e 100644
--- a/app-office/oooqs/files/fixxooo.patch
+++ b/app-office/oooqs/files/fixxooo.patch
@@ -1,5 +1,6 @@
---- src/oooqs.cpp 2004-08-25 13:57:33.801575240 +0200
-+++ src/oooqs.cpp 2004-08-25 13:57:33.802575088 +0200
+diff -ru oooqs-2.0.3/src/oooqs.cpp oooqs-2.0.3-fixed/src/oooqs.cpp
+--- oooqs-2.0.3/src/oooqs.cpp 2005-06-01 20:08:30.000000000 +0300
++++ oooqs-2.0.3-fixed/src/oooqs.cpp 2005-06-01 20:07:55.000000000 +0300
@@ -3,6 +3,7 @@
*/
@@ -8,7 +9,59 @@
#include <qmap.h>
#include <kaboutdata.h>
-@@ -92,9 +93,15 @@
+@@ -44,21 +45,36 @@
+ */
+ KPopupMenu* menu = contextMenu();
+
+- ( new KAction( i18n( "Textdocument" ),
+- "ooo_writer", 0, this,
+- SLOT( startWriter() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "Spreadsheet" ),
+- "ooo_calc", 0, this,
+- SLOT( startCalc() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "Presentation" ),
+- "ooo_impress", 0, this,
+- SLOT( startImpress() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "Drawing" ),
+- "ooo_draw", 0, this,
+- SLOT( startDraw() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "From Template" ),
+- "wizard", 0, this,
+- SLOT( startTemplate() ), this ) ) ->plug( menu );
++ if ( QFile::exists( QDir::homeDirPath() + QDir::separator() + ".xversionrc" ) ) {
++ ( new KAction( i18n( "Textdocument" ),
++ "ximian-openoffice-writer", 0, this,
++ SLOT( startWriter() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Spreadsheet" ),
++ "ximian-openoffice-calc", 0, this,
++ SLOT( startCalc() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Presentation" ),
++ "ximian-openoffice-impress", 0, this,
++ SLOT( startImpress() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Drawing" ),
++ "ximian-openoffice-draw", 0, this,
++ SLOT( startDraw() ), this ) ) ->plug( menu );
++ } else {
++ ( new KAction( i18n( "Textdocument" ),
++ "ooo_writer", 0, this,
++ SLOT( startWriter() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Spreadsheet" ),
++ "ooo_calc", 0, this,
++ SLOT( startCalc() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Presentation" ),
++ "ooo_impress", 0, this,
++ SLOT( startImpress() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Drawing" ),
++ "ooo_draw", 0, this,
++ SLOT( startDraw() ), this ) ) ->plug( menu );
++ }
++ ( new KAction( i18n( "From Template" ),
++ "wizard", 0, this,
++ SLOT( startTemplate() ), this ) ) ->plug( menu );
+ menu->insertSeparator();
+ ( new KAction( i18n( "Open Document" ),
+ "fileopen", 0, this,
+@@ -92,9 +108,15 @@
Try to autodetect settings if they aren't found in our own config.
*/
if ( _exec.length() < 2 ) {
@@ -17,13 +70,13 @@
- + ".sversionrc", true );
+ if ( QFile::exists( QDir::homeDirPath() + QDir::separator() + ".xversionrc" ) ) {
+ oooConfig = new KSimpleConfig(
-+ QDir::homeDirPath() + QDir::separator()
-+ + ".xversionrc", true );
-+ } else {
++ QDir::homeDirPath() + QDir::separator()
++ + ".xversionrc", true );
++ } else {
+ oooConfig = new KSimpleConfig(
-+ QDir::homeDirPath() + QDir::separator()
-+ + ".sversionrc", true );
-+}
++ QDir::homeDirPath() + QDir::separator()
++ + ".sversionrc", true );
++ }
oooConfig->setGroup( "Versions" );
versions = oooConfig->entryMap( "Versions" );
/**