summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-09-14 05:32:36 +0000
committerMike Gardiner <obz@gentoo.org>2003-09-14 05:32:36 +0000
commitd1dc2e87b3785735c20eb09cc6f639849de76341 (patch)
tree266d46bb3b187006d253092866c087e1d5fb99ad /app-office
parentgcc3 patch (diff)
downloadhistorical-d1dc2e87b3785735c20eb09cc6f639849de76341.tar.gz
historical-d1dc2e87b3785735c20eb09cc6f639849de76341.tar.bz2
historical-d1dc2e87b3785735c20eb09cc6f639849de76341.zip
New version
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmacs/ChangeLog7
-rw-r--r--app-office/texmacs/Manifest3
-rw-r--r--app-office/texmacs/texmacs-1.0.1.23.ebuild55
3 files changed, 63 insertions, 2 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 2b821df81376..b6f8735fd45c 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmacs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.11 2003/09/13 07:25:31 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.12 2003/09/14 05:32:26 obz Exp $
+
+*texmacs-1.0.1.23 (14 Sep 2003)
+
+ 14 Sep 2003; Mike Gardiner <obz@gentoo.org> texmacs-1.0.1.23.ebuild:
+ New version
*texmacs-1.0.1-r1 (13 Sep 2003)
diff --git a/app-office/texmacs/Manifest b/app-office/texmacs/Manifest
index 7ea443f53de5..228c4487f7b6 100644
--- a/app-office/texmacs/Manifest
+++ b/app-office/texmacs/Manifest
@@ -1,7 +1,8 @@
MD5 1d73ecad3e49d2a43236ea1158177088 texmacs-1.0.0.19.ebuild 1004
MD5 4613729da8519378983c80c8eef1b3f9 texmacs-1.0.1-r1.ebuild 1150
MD5 6c87bf424dde1183a5211fb1e278bca8 texmacs-1.0.1.ebuild 1102
-MD5 eb3e417cc1796e872eeb7577d20b291d ChangeLog 1674
+MD5 df62145c8b16195fb0a8f7d9b767f631 ChangeLog 1793
+MD5 f7562f593f52893ad8a8974973bbe101 texmacs-1.0.1.23.ebuild 1357
MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 4e64086a3b4c9a500cf4d4bbd8ca3e5f files/digest-texmacs-1.0.0.19 146
MD5 e66f431d3e08f7c71c8b3838c9601369 files/digest-texmacs-1.0.1-r1 143
diff --git a/app-office/texmacs/texmacs-1.0.1.23.ebuild b/app-office/texmacs/texmacs-1.0.1.23.ebuild
new file mode 100644
index 000000000000..220edbcb38c1
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.1.23.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.1.23.ebuild,v 1.1 2003/09/14 05:32:26 obz Exp $
+
+# flag-o-matic functions now in portage, no need to inherit it
+
+MY_P=${P/tex/TeX}-src
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GNU Emacs."
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="spell"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=app-text/tetex-1.0.7-r7
+ >=dev-util/guile-1.4
+ >=sys-apps/sed-4
+ virtual/x11
+ spell? ( >=app-text/ispell-3.2 )"
+
+DEPEND="${DEPEND}
+ app-text/ghostscript"
+
+src_compile() {
+
+ # we're not trusting texmacs optimisations here, so
+ # we only want the following two
+ strip-flags
+ append-flags -fno-default-inline
+ append-flags -fno-inline
+
+ econf || die
+ # and now replace the detected optimisations with our safer ones
+ sed -i "s:\(^CXXOPTIMIZE = \).*:\1${CXXFLAGS}:" src/common.makefile
+ emake || die
+
+}
+
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ dodoc COMPILE COPYING LICENSE
+
+ # now install the fonts
+ cd ${WORKDIR}
+ dodir /usr/share/texmf
+ cp -r fonts ${D}/usr/share/texmf/
+
+}