summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-22 23:40:32 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-22 23:40:32 +0000
commitdbf4cc221825f8d66d0cb47f0373883b70b5587e (patch)
tree044cce8f33fcf933ccf9b70036a6c451e68b059f /app-office
parentversion bump (diff)
downloadhistorical-dbf4cc221825f8d66d0cb47f0373883b70b5587e.tar.gz
historical-dbf4cc221825f8d66d0cb47f0373883b70b5587e.tar.bz2
historical-dbf4cc221825f8d66d0cb47f0373883b70b5587e.zip
new dev version
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-1.9.0.ebuild75
-rw-r--r--app-office/abiword/files/digest-abiword-1.9.01
3 files changed, 82 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 5cf7afff0886..7872a44edea1 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.32 2003/04/08 12:13:17 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.33 2003/04/22 23:40:32 foser Exp $
+
+*abiword-1.9.0 (23 Apr 2003)
+
+ 23 Apr 2003; foser <foser@gentoo.org> abiword-1.9.0.ebuild :
+ New devel version, removed the wv configure patch, doesn't seem necessary anymore
*abiword-1.1.4 (31 Mar 2003)
diff --git a/app-office/abiword/abiword-1.9.0.ebuild b/app-office/abiword/abiword-1.9.0.ebuild
new file mode 100644
index 000000000000..47dbcf9485d1
--- /dev/null
+++ b/app-office/abiword/abiword-1.9.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.9.0.ebuild,v 1.1 2003/04/22 23:40:32 foser Exp $
+
+inherit eutils
+
+IUSE="perl build spell jpeg xml2 gnome"
+
+S=${WORKDIR}/${P}/abi
+DESCRIPTION="Fully featured yet light and fast cross platform word processor."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.abisource.com"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="GPL-2"
+SLOT="2"
+
+DEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ >=dev-libs/libole2-0.2.4-r1
+ >=x11-libs/gtk+-2
+ >=app-text/wv-0.7.5
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ perl? ( >=dev-lang/perl-5.6 )
+ ( xml2? >=dev-libs/libxml2-2.4.10 : dev-libs/expat )
+ spell? ( >=app-text/aspell-0.50.3 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-extra/gal-1.99 )
+ !app-shells/bash-completion"
+
+# FIXME : do 'real' use switching, add gucharmap support
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ econf ${myconf} --with-sys-wv || die
+
+ emake all-recursive || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:${D}::g" /usr/bin/AbiWord-2.0
+
+ rm -f ${D}/usr/bin/abiword-2.0
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.0 /usr/bin/abiword-2.0
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/applications/
+ doins ${FILESDIR}/AbiWord2.desktop
+ # Not installing oaf files, not overly stable.
+ )
+}
+
+pkg_postinst() {
+ einfo "For stability, install the latest 1.0.x release."
+}
+
diff --git a/app-office/abiword/files/digest-abiword-1.9.0 b/app-office/abiword/files/digest-abiword-1.9.0
new file mode 100644
index 000000000000..cae50061e598
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.9.0
@@ -0,0 +1 @@
+MD5 3933eae8fe1d064028f9f9b407f1ce9f abiword-1.9.0.tar.bz2 10767685