summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-17 05:38:37 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-17 05:38:37 +0000
commit8412f6b324aa60d684fac819830a6db8f8d4c010 (patch)
tree6590ce669ccbe784930e0cd95205e647dd62dd99 /app-pda/jpilot/jpilot-0.99.9.ebuild
parentRemove old version (diff)
downloadhistorical-8412f6b324aa60d684fac819830a6db8f8d4c010.tar.gz
historical-8412f6b324aa60d684fac819830a6db8f8d4c010.tar.bz2
historical-8412f6b324aa60d684fac819830a6db8f8d4c010.zip
Version bump to 0.99.9 with several fixes. Removed obsolete versions.
Fixes bugs 93471, 128076, 148440 and 160349. Thanks to (in order of appearance) Craig Lawson, Mark Wagner, Serhij S. Stasyuk and Thomas Jost for their contributions! Package-Manager: portage-2.1.3.9
Diffstat (limited to 'app-pda/jpilot/jpilot-0.99.9.ebuild')
-rw-r--r--app-pda/jpilot/jpilot-0.99.9.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-pda/jpilot/jpilot-0.99.9.ebuild b/app-pda/jpilot/jpilot-0.99.9.ebuild
new file mode 100644
index 000000000000..4982ec0b27c1
--- /dev/null
+++ b/app-pda/jpilot/jpilot-0.99.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.9.ebuild,v 1.1 2007/09/17 05:38:36 philantrop Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+HOMEPAGE="http://jpilot.org/"
+SRC_URI="http://jpilot.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=app-pda/pilot-link-0.11.8
+ >=x11-libs/gtk+-2.6.10-r1
+ nls? ( sys-devel/gettext )
+ >=dev-perl/XML-Parser-2.34"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fixes bug 93471.
+ epatch "${FILESDIR}/${P}-keyring-cats.patch"
+
+ # There are four icons available. Use the third.
+ sed -i -e 's/jpilot.xpm/jpilot-icon3.xpm/' jpilot.desktop || die "sed'ing the desktop file failed"
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" \
+ libdir=/usr/$(get_libdir)/jpilot/plugins \
+ docdir=/usr/share/doc/${PF} \
+ icondir=/usr/share/pixmaps \
+ desktopdir=/usr/share/applications || die "install failed"
+
+ dodoc ABOUT-NLS AUTHORS BUGS ChangeLog INSTALL NEWS README TODO || die "installing docs failed"
+ doman docs/*.1
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins "${S}"/jpilotrc.*
+}
+
+pkg_postinst() {
+ elog
+ elog "The jpilot-syncmal plugin has moved to its own ebuild."
+ elog "If you want to use that plugin, please run"
+ elog " emerge jpilot-syncmal"
+ elog
+ elog "There are other plugins available as well. To see the"
+ elog "list, please run"
+ elog " emerge -s jpilot"
+ elog
+}