summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2011-02-18 06:21:48 +0000
committerRyan Hill <rhill@gentoo.org>2011-02-18 06:21:48 +0000
commit59938f525003b912ad242f6ff90086d04d5b80d9 (patch)
treebe98a589da1dbc0a8efe22e1214d06dfda73db6b /app-pda/libopensync/libopensync-0.22-r1.ebuild
parentadd ~x64-macos (diff)
downloadhistorical-59938f525003b912ad242f6ff90086d04d5b80d9.tar.gz
historical-59938f525003b912ad242f6ff90086d04d5b80d9.tar.bz2
historical-59938f525003b912ad242f6ff90086d04d5b80d9.zip
Prevent relinking against outgoing system libs on downgrade (bug #355291).
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'app-pda/libopensync/libopensync-0.22-r1.ebuild')
-rw-r--r--app-pda/libopensync/libopensync-0.22-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-pda/libopensync/libopensync-0.22-r1.ebuild b/app-pda/libopensync/libopensync-0.22-r1.ebuild
index 4897c74423ce..2a2022a28939 100644
--- a/app-pda/libopensync/libopensync-0.22-r1.ebuild
+++ b/app-pda/libopensync/libopensync-0.22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.22-r1.ebuild,v 1.1 2011/02/14 20:14:23 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.22-r1.ebuild,v 1.2 2011/02/18 06:21:48 dirtyepic Exp $
EAPI="3"
@@ -36,8 +36,11 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-fbsd.patch
epatch "${FILESDIR}"/${P}-pythonpath.patch
epatch "${FILESDIR}"/${P}-swig-typeerror.patch
- eautoreconf # for pythonpath
- find "${S}" -name Makefile.in -print0 | xargs -0 sed -i -e 's: -Werror::'
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ eautoreconf
+
+ find "${S}" -name Makefile.in -print0 | xargs -0 sed -i -e 's: -Werror::' \
+ -e 's: -R $(libdir)::g'
use python && python_copy_sources
}
@@ -51,10 +54,15 @@ src_configure() {
$(use_enable debug) \
$(use_enable debug tracing)
#$(use_enable test unit-tests)
+
+ sed -i -e 's:^\(hardcode_libdir_flag_spec=\).*:\1"":g' \
+ -e 's:^\(runpath_var=\).*:\1DIE_RPATH_DIE:g' \
+ -e 's:func_apped:func_append:g' \
+ libtool
}
use python && python_execute_function -s do_configure
- do_configure # do even when USE=python to generate Doxyfile in ${S}
+ do_configure # do this even when USE=python - we need to generate Doxyfile
}
src_compile() {