summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-12-17 22:52:39 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-12-17 22:52:39 +0000
commita0baf9db03ad02e7abc42b6f2de865eefe5a6448 (patch)
treeb8b16df7469fc1c81899c8c9c387d0d406f2674d /app-pda/plptools/plptools-0.11.ebuild
parentdowngraded back to testing due to b0rking stage1 builds (diff)
downloadhistorical-a0baf9db03ad02e7abc42b6f2de865eefe5a6448.tar.gz
historical-a0baf9db03ad02e7abc42b6f2de865eefe5a6448.tar.bz2
historical-a0baf9db03ad02e7abc42b6f2de865eefe5a6448.zip
Initial submission per Bug#9820
Diffstat (limited to 'app-pda/plptools/plptools-0.11.ebuild')
-rw-r--r--app-pda/plptools/plptools-0.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-pda/plptools/plptools-0.11.ebuild b/app-pda/plptools/plptools-0.11.ebuild
new file mode 100644
index 000000000000..ee11a75f7be6
--- /dev/null
+++ b/app-pda/plptools/plptools-0.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Libraries and utilities to communicate with a Psion palmtop via serial."
+HOMEPAGE="http://plptools.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/plptools/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/glibc"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch | die "Patch failed!"
+
+ local myconf
+
+ myconf="${myconf} --disable-kde"
+
+ ./configure ${myconf} --prefix=/usr || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES README TODO
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/psion.conf psion
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/psion
+}