summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-11 23:53:51 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-11 23:53:51 +0000
commit9a33ab94ad7177edd25125f54baa700bce06e7d2 (patch)
treeb663c2f54fec7fc1658090e8a50c901b89fcb552 /app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild
parentforget that (diff)
downloadhistorical-9a33ab94ad7177edd25125f54baa700bce06e7d2.tar.gz
historical-9a33ab94ad7177edd25125f54baa700bce06e7d2.tar.bz2
historical-9a33ab94ad7177edd25125f54baa700bce06e7d2.zip
Add patch for bug 153973 - stop spewing debug files into $HOME
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild')
-rw-r--r--app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild b/app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..bffaa8a1224e
--- /dev/null
+++ b/app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.9.1-r1.ebuild,v 1.1 2006/12/11 23:53:51 masterdriverz Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/check-0.8.2
+ >=dev-libs/libmimedir-0.4
+ >=app-pda/synce-libsynce-0.9.1
+ >=app-pda/synce-librapi2-0.9.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-textrel.patch
+ epatch "${FILESDIR}"/${P}-nowerror.patch
+ epatch "${FILESDIR}"/${P}-make_debug.patch
+ eautoreconf || die 'eautoreconf failed'
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+}