summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-01-03 03:04:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-01-03 03:04:47 +0000
commit63016caa2760233430898dd875120497a4076cac (patch)
tree26e04bb0d5f8f1b450a70a2422dd9d018fb04fad /app-pda
parentFix array usage with $A so it actually works #76428 by Francois Guimond. (diff)
downloadhistorical-63016caa2760233430898dd875120497a4076cac.tar.gz
historical-63016caa2760233430898dd875120497a4076cac.tar.bz2
historical-63016caa2760233430898dd875120497a4076cac.zip
Version bumped.
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/gnupod/ChangeLog7
-rw-r--r--app-pda/gnupod/Manifest6
-rw-r--r--app-pda/gnupod/files/digest-gnupod-0.971
-rw-r--r--app-pda/gnupod/gnupod-0.97.ebuild43
4 files changed, 54 insertions, 3 deletions
diff --git a/app-pda/gnupod/ChangeLog b/app-pda/gnupod/ChangeLog
index 7f295487d57a..dadf60975d73 100644
--- a/app-pda/gnupod/ChangeLog
+++ b/app-pda/gnupod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/gnupod
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnupod/ChangeLog,v 1.6 2005/01/01 15:43:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnupod/ChangeLog,v 1.7 2005/01/03 03:04:46 matsuu Exp $
+
+*gnupod-0.97 (03 Jan 2005)
+
+ 03 Jan 2005; MATSUU Takuto <matsuu@gentoo.org> +gnupod-0.97.ebuild:
+ Version bumped.
*gnupod-0.94 (23 Jun 2004)
diff --git a/app-pda/gnupod/Manifest b/app-pda/gnupod/Manifest
index 6898b09b367c..0d662ababf0a 100644
--- a/app-pda/gnupod/Manifest
+++ b/app-pda/gnupod/Manifest
@@ -1,6 +1,8 @@
-MD5 311121fac41169cbcb83f6758cb4f904 ChangeLog 679
+MD5 58f1a82e5935ef6e987b5f8c53404bff gnupod-0.94.ebuild 1014
+MD5 db546d29861e18b039c67563d47ee275 gnupod-0.97.ebuild 1014
MD5 60daabb01cf25ffc73fa2cff22c33b2c gnupod-0.27.ebuild 1888
+MD5 4b03ab19bb6e7b007b45b1b95c3ee1d7 ChangeLog 792
MD5 075fea99b82d61028585dc3e42f00466 metadata.xml 156
-MD5 58f1a82e5935ef6e987b5f8c53404bff gnupod-0.94.ebuild 1014
MD5 6ebe359f3cb9294398e187d7239a9400 files/digest-gnupod-0.27 68
MD5 2e05183c0d3af4eb2194591d263b6e7d files/digest-gnupod-0.94 60
+MD5 644e45ce76da0a2dbbedeabb3d36a769 files/digest-gnupod-0.97 60
diff --git a/app-pda/gnupod/files/digest-gnupod-0.97 b/app-pda/gnupod/files/digest-gnupod-0.97
new file mode 100644
index 000000000000..ef473ee98dd0
--- /dev/null
+++ b/app-pda/gnupod/files/digest-gnupod-0.97
@@ -0,0 +1 @@
+MD5 ed9969cd2c04fe67366fe619a14940f0 gnupod-0.97.tgz 148311
diff --git a/app-pda/gnupod/gnupod-0.97.ebuild b/app-pda/gnupod/gnupod-0.97.ebuild
new file mode 100644
index 000000000000..e628171a5827
--- /dev/null
+++ b/app-pda/gnupod/gnupod-0.97.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnupod/gnupod-0.97.ebuild,v 1.1 2005/01/03 03:04:47 matsuu Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl-scripts for iPod"
+HOMEPAGE="http://www.gnu.org/software/gnupod/"
+SRC_URI="http://blinkenlights.ch/gnupod-dist/stable/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+# perl-5.8.0 contains Getopt-Long and Digest-MD5.
+DEPEND="dev-lang/perl
+ dev-perl/MP3-Info
+ dev-perl/XML-Parser
+ dev-perl/Unicode-String
+ || ( >=dev-lang/perl-5.8.0
+ ( dev-perl/Getopt-Long
+ dev-perl/Digest-MD5
+ )
+ )"
+
+src_compile() {
+ econf || die
+}
+
+src_install() {
+ perlinfo
+ sed -i -e "s:\$INC\[0\]/\$modi:${D}${VENDOR_ARCH}/\$modi:g" \
+ tools/gnupod_install.pl || die
+
+ dodir /usr/bin
+ dodir ${VENDOR_ARCH}/GNUpod
+ dodir /usr/share/info
+ einstall || die
+
+ dodoc AUTHORS BUGS CHANGES README* TODO doc/gnutunesdb.example
+ dohtml doc/gnupod.html
+}