summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-06-01 17:11:58 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-06-01 17:11:58 +0000
commitdb8f8e440a1886cd525dde19d2d823410a8f0998 (patch)
tree0a891860e7fb75af0b49455174d9fa3053c9a16b /app-sci/snns
parentVersion bump. (diff)
downloadhistorical-db8f8e440a1886cd525dde19d2d823410a8f0998.tar.gz
historical-db8f8e440a1886cd525dde19d2d823410a8f0998.tar.bz2
historical-db8f8e440a1886cd525dde19d2d823410a8f0998.zip
Integrated the python module from snns-dev.berlios.de
Diffstat (limited to 'app-sci/snns')
-rw-r--r--app-sci/snns/ChangeLog7
-rw-r--r--app-sci/snns/Manifest4
-rw-r--r--app-sci/snns/files/digest-snns-4.2-r54
-rw-r--r--app-sci/snns/snns-4.2-r5.ebuild106
4 files changed, 119 insertions, 2 deletions
diff --git a/app-sci/snns/ChangeLog b/app-sci/snns/ChangeLog
index 0241d26f89e6..49c539f90d46 100644
--- a/app-sci/snns/ChangeLog
+++ b/app-sci/snns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/snns
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.11 2004/04/25 22:54:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.12 2004/06/01 17:11:58 phosphan Exp $
+
+*snns-4.2-r5 (01 Jun 2004)
+
+ 01 Jun 2004; Patrick Kursawe <phosphan@gentoo.org> snns-4.2-r5.ebuild:
+ Integrated the python bindings from the snns-dev project.
25 Apr 2004; Aron Griffis <agriffis@gentoo.org> snns-4.2-r4.ebuild:
Add die following econf for bug 48950
diff --git a/app-sci/snns/Manifest b/app-sci/snns/Manifest
index 1001537d5319..2a817d4027aa 100644
--- a/app-sci/snns/Manifest
+++ b/app-sci/snns/Manifest
@@ -1,4 +1,6 @@
+MD5 eedd41bf5ab709d5cff59cd23d4583f0 snns-4.2-r5.ebuild 2528
MD5 2cf3c42790ccc3b2c18a5ebd15a7511c snns-4.2-r4.ebuild 1653
-MD5 175911e5d7d225acb4e18e8c5ea9c6d6 ChangeLog 1572
+MD5 b899b472d6c05d34deae0033de9635da ChangeLog 1734
MD5 c000c0728c9136f1b54cbc3a5fc07644 metadata.xml 220
MD5 409a7ed863845a91ab923aee9873a062 files/digest-snns-4.2-r4 196
+MD5 228f8f47f6f6361ea57cd4f4f9b74d9d files/digest-snns-4.2-r5 262
diff --git a/app-sci/snns/files/digest-snns-4.2-r5 b/app-sci/snns/files/digest-snns-4.2-r5
new file mode 100644
index 000000000000..d531d8368c2b
--- /dev/null
+++ b/app-sci/snns/files/digest-snns-4.2-r5
@@ -0,0 +1,4 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 73a999a41bb91a4f8b5653ddddfcc527 snns-4.2-20040227.patch.gz 55476
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
+MD5 8d1e85ecee6bf2449f5e570c094b5827 PySNNS-20040601.tar.gz 16840
diff --git a/app-sci/snns/snns-4.2-r5.ebuild b/app-sci/snns/snns-4.2-r5.ebuild
new file mode 100644
index 000000000000..df5205ab4356
--- /dev/null
+++ b/app-sci/snns/snns-4.2-r5.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2-r5.ebuild,v 1.1 2004/06/01 17:11:58 phosphan Exp $
+
+inherit eutils python
+
+MY_P="SNNSv${PV}"
+MYPATCH="${P}-20040227"
+MYPYTHONEXT="PySNNS-20040601"
+
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ http://download.berlios.de/snns-dev/${MYPATCH}.patch.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )
+ python? ( http://download.berlios.de/snns-dev/${MYPYTHONEXT}.tar.gz )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="X doc python"
+
+DEPEND="X? ( virtual/x11
+ x11-libs/Xaw3d )
+ >=sys-apps/sed-4
+ python? ( >=dev-lang/python-2.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack ${MYPATCH}.patch.gz
+ epatch ${MYPATCH}.patch
+ use python && unpack ${MYPYTHONEXT}.tar.gz
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake ${compileopts} || die "emake failed"
+
+ if use python; then
+ cd python
+ python setup.py build || die "could not build python extension"
+ fi
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if use X; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ if use python; then
+ cd python
+ python setup.py install --prefix=${D}/usr || die "could not install python module"
+ cp -a examples ${D}/usr/share/doc/${PF}/python-examples
+ chmod +x ${D}/usr/share/doc/${PF}/python-examples/*.py
+ newdoc README README.python
+ cd ${S}
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}
+
+pkg_postinst() {
+ if use python; then
+ einfo "Pre-compiling Python module"
+ python_version
+ for file in __init__.py util.py; do
+ python_mod_compile \
+ ${ROOT}/usr/lib/python${PYVER}/site-packages/snns/${file}
+ done
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ einfo "Cleaning up python stuff"
+ python_mod_cleanup
+ fi
+}