summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-09-16 19:16:54 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-09-16 19:16:54 +0000
commitdb43bebf9bcbbf5933812e5ae5791e57fe503c55 (patch)
treed1514b455c21a0cf80b58ea9d2e666007c724d22 /app-sci/staden
parentInitial import (package masked) (diff)
downloadhistorical-db43bebf9bcbbf5933812e5ae5791e57fe503c55.tar.gz
historical-db43bebf9bcbbf5933812e5ae5791e57fe503c55.tar.bz2
historical-db43bebf9bcbbf5933812e5ae5791e57fe503c55.zip
Fixed a bug with optional EMBOSS support.
Diffstat (limited to 'app-sci/staden')
-rw-r--r--app-sci/staden/ChangeLog8
-rw-r--r--app-sci/staden/files/digest-staden-1.4.1-r3 (renamed from app-sci/staden/files/digest-staden-1.4.1-r2)0
-rw-r--r--app-sci/staden/staden-1.4.1-r3.ebuild (renamed from app-sci/staden/staden-1.4.1-r2.ebuild)33
3 files changed, 14 insertions, 27 deletions
diff --git a/app-sci/staden/ChangeLog b/app-sci/staden/ChangeLog
index c3ec0ff92937..83ab9ba64a62 100644
--- a/app-sci/staden/ChangeLog
+++ b/app-sci/staden/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/staden
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/ChangeLog,v 1.3 2004/09/16 04:12:35 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/ChangeLog,v 1.4 2004/09/16 19:16:54 ribosome Exp $
+
+*staden-1.4.1-r3 (16 Sep 2004)
+
+ 16 Sep 2004; Olivier Fisette <ribosome@gentoo.org> -staden-1.4.1-r2.ebuild,
+ +staden-1.4.1-r3.ebuild:
+ Fixed problem with EMBOSS GUIs failing to compile.
*staden-1.4.1-r2 (16 Sep 2004)
diff --git a/app-sci/staden/files/digest-staden-1.4.1-r2 b/app-sci/staden/files/digest-staden-1.4.1-r3
index eb3556875249..eb3556875249 100644
--- a/app-sci/staden/files/digest-staden-1.4.1-r2
+++ b/app-sci/staden/files/digest-staden-1.4.1-r3
diff --git a/app-sci/staden/staden-1.4.1-r2.ebuild b/app-sci/staden/staden-1.4.1-r3.ebuild
index 10951a49085c..011adde20199 100644
--- a/app-sci/staden/staden-1.4.1-r2.ebuild
+++ b/app-sci/staden/staden-1.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/staden-1.4.1-r2.ebuild,v 1.1 2004/09/16 04:12:35 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/staden/staden-1.4.1-r3.ebuild,v 1.1 2004/09/16 19:16:54 ribosome Exp $
inherit eutils
@@ -17,7 +17,6 @@ IUSE="doc emboss ifc"
DEPEND="${RDEPEND}
dev-lang/perl
- emboss? ( app-sci/emboss )
ifc? ( dev-lang/ifc )"
RDEPEND="app-shells/ksh
@@ -28,6 +27,8 @@ RDEPEND="app-shells/ksh
media-libs/libpng
virtual/x11"
+PDEPEND="emboss? ( app-sci/staden-emboss )"
+
S=${WORKDIR}/${PN}-src-rel-${PV//./-}
pkg_setup() {
@@ -52,21 +53,6 @@ pkg_setup() {
fi
die "Fortran compiler not found."
fi
-
- # Check for X authority if building the EMBOSS tcl/tk GUIs.
- if use "emboss" && [ -z ${XAUTHORITY} ]; then
- echo
- eerror 'The "XAUTHORITY" environment variable is not set on your system.'
- eerror 'Access to an X display is required to build the EMBOSS tcl/tk GUIs.'
- eerror 'Please either unset the "emboss" "USE" flag to install this package'
- eerror 'without building the EMBOSS GUIs (you will still be provided with a'
- eerror 'set of prebuilt GUIs) or configure access to an X display. You can'
- eerror 'transfer the X credentials of an ordinary user to the account you'
- eerror 'use to execute "emerge" with the "sux" command, which is part of the'
- eerror '"x11-misc/sux" package. See: "http://www.gentoo.org/doc/en/su-x.xml"'
- eerror 'for an introduction to installing and using "sux" on Gentoo.'
- die '"XAUTHORITY" not set.'
- fi
}
src_unpack() {
@@ -156,15 +142,16 @@ src_compile() {
# Patched version of iwidgetsrc
cp ${FILESDIR}/${P}-iwidgetsrc.new ${S}/tables/iwidgetsrc
- # Build tcl/tk GUIs for EMBOSS programs if requested.
- use "emboss" && STADENROOT="${S}" ${S}/linux-bin/create_emboss_files
-
# Netscape is not a good default browser (security masked in Portage).
# Use documentation.html rather than staden_home.html as the top-level
# hypertext documentation file.
cp ${FILESDIR}/${P}-staden_help.new ${S}/linux-bin/staden_help
chmod +x ${S}/linux-bin/staden_help
+ # Remove the prebuilt EMBOSS tcl/tk GUIs.
+ rm ${S}/tables/emboss_menu
+ rm -r ${S}/lib/spin2_emboss/acdtcl
+
}
src_install() {
@@ -191,7 +178,6 @@ src_install() {
# A short course in printable format along with some data
use doc && mv ${WORKDIR}/course ${D}/opt/${PN}/course
-
}
pkg_postinst() {
@@ -210,10 +196,5 @@ pkg_postinst() {
ewarn '"strace" to identify the problematic font(s) and either uninstall'
ewarn 'them or remove the directory they are in from "FontPath" by'
ewarn 'editing your X server configuration file.'
- ewarn
- ewarn 'The default EMBOSS tcl/tk GUIs (which get installed if you did not'
- ewarn 'set the "emboss" "USE" flag) are way out of date, while the custom'
- ewarn 'GUIs (which are built if you set the "emboss" "USE" flag) do not'
- ewarn 'support many of the most recent EMBOSS/EMBASSY programs.'
echo
}