summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-04-29 06:17:54 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-04-29 06:17:54 +0000
commitb13f69fc95868b3c75f1c82624baa025411592b6 (patch)
tree7c28fbd08c6a6c7057abacbd9ac0b9b09612d34d /app-sci
parentufed-0.31 comitted in unstable (diff)
downloadhistorical-b13f69fc95868b3c75f1c82624baa025411592b6.tar.gz
historical-b13f69fc95868b3c75f1c82624baa025411592b6.tar.bz2
historical-b13f69fc95868b3c75f1c82624baa025411592b6.zip
few minor touchups
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/spice/ChangeLog7
-rw-r--r--app-sci/spice/spice-3.5.5.ebuild20
2 files changed, 17 insertions, 10 deletions
diff --git a/app-sci/spice/ChangeLog b/app-sci/spice/ChangeLog
index 8e56ab1421dc..8017af046d1f 100644
--- a/app-sci/spice/ChangeLog
+++ b/app-sci/spice/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for app-sci/spice
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/spice/ChangeLog,v 1.3 2003/02/12 05:19:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spice/ChangeLog,v 1.4 2003/04/29 06:17:54 george Exp $
+
+ 28 Apr 2003; George Shapovalov <george@gentoo.org> spice-3.5.5.ebuild :
+ few cosmetic touches + added ISUE; made ebuild honor EDITOR setting on user system
*spice-3.5.5 (7 Aug 2002)
- 07 Aug 2002; G. Shapovalov <george@gentoo.org> spice-3.5.5.ebuild, files/digest-spice-3.5.5:
+ 07 Aug 2002; George Shapovalov <george@gentoo.org> spice-3.5.5.ebuild, files/digest-spice-3.5.5:
initial release
diff --git a/app-sci/spice/spice-3.5.5.ebuild b/app-sci/spice/spice-3.5.5.ebuild
index eb66c56648ac..2e9884ccacd8 100644
--- a/app-sci/spice/spice-3.5.5.ebuild
+++ b/app-sci/spice/spice-3.5.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/spice/spice-3.5.5.ebuild,v 1.5 2003/03/01 03:43:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/spice/spice-3.5.5.ebuild,v 1.6 2003/04/29 06:17:54 george Exp $
+
+IUSE=""
MY_P="spice3f5sfix"
DESCRIPTION="general-purpose circuit simulation program"
@@ -11,20 +13,21 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
-DEPEND="virtual/glibc
- sys-libs/ncurses"
+DEPEND="sys-libs/ncurses"
S=${WORKDIR}/${MY_P}
src_unpack() {
- unpack ${A} ; cd ${S}/conf
- cp linux{,.orig}
+ unpack ${A}
+ cd ${S}/conf
+ [ -z $EDITOR ] || EDITOR="vim"
+# cp linux{,.orig}
sed -e "s:termcap:ncurses:g" \
- -e "s:joe:emacs:g" \
+ -e "s:joe:${EDITOR}:g" \
-e "s:-O2 -s:${CFLAGS}:g" \
-e "s:SPICE_DIR)/lib:SPICE_DIR)/lib/spice:g" \
-e "s:/usr/local/spice:/usr:g" \
- linux.orig > linux
+ -i.orig linux
}
src_compile() {
@@ -33,6 +36,7 @@ src_compile() {
}
src_install() {
+ cd ${S}
# install binaries
dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod}
newbin obj/bin/help spice.help
@@ -43,5 +47,5 @@ src_install() {
cp -R lib/* ${D}/usr/lib/spice/
# install docs
doman man/man1/*.1
- dodoc doc readme readme.Linux notes/spice2
+ dodoc readme readme.Linux notes/spice2
}