summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 14:44:51 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 14:44:51 +0000
commitb65c5b21593a91524969ebc31e11cff5872ae9d1 (patch)
tree3ce8fb76837d46dac0dea3700a3948a6cab07436 /app-sci
parentChanged einstall||die to einstall (diff)
downloadhistorical-b65c5b21593a91524969ebc31e11cff5872ae9d1.tar.gz
historical-b65c5b21593a91524969ebc31e11cff5872ae9d1.tar.bz2
historical-b65c5b21593a91524969ebc31e11cff5872ae9d1.zip
Changed econf||die to econf
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/pariguide/pariguide-0.43a.ebuild19
-rw-r--r--app-sci/snac/snac-0.3.ebuild15
-rw-r--r--app-sci/systemc/systemc-2.0.1.ebuild18
3 files changed, 17 insertions, 35 deletions
diff --git a/app-sci/pariguide/pariguide-0.43a.ebuild b/app-sci/pariguide/pariguide-0.43a.ebuild
index c9a958e02d8d..8a8e69f035de 100644
--- a/app-sci/pariguide/pariguide-0.43a.ebuild
+++ b/app-sci/pariguide/pariguide-0.43a.ebuild
@@ -1,28 +1,21 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/pariguide/pariguide-0.43a.ebuild,v 1.1 2002/12/15 23:07:28 george Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-sci/pariguide/pariguide-0.43a.ebuild,v 1.2 2002/12/18 14:44:51 vapier Exp $
DESCRIPTION="PariGUIde, a GUI for the math. program Pari-GP"
HOMEPAGE="http://www.skalatan.de/pariguide/"
-SRC_URI="ftp://ftp.sourceforge.net/pub/sourceforge/pariguide/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/pariguide/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-DEPEND=">=qt-2.2.0
- virtual/x11"
-
-RDEPEND=">=pari-2.1.0"
-
-S="${WORKDIR}/${P}"
+DEPEND=">=x11-libs/qt-2.2.0
+ virtual/x11"
+RDEPEND=">=app-sci/pari-2.1.0"
src_compile() {
- #./configure \
- # --host=${CHOST} \
- econf || die "configure failed"
+ econf
emake || die
}
diff --git a/app-sci/snac/snac-0.3.ebuild b/app-sci/snac/snac-0.3.ebuild
index d15988a0e1bb..6064ee5a3b90 100644
--- a/app-sci/snac/snac-0.3.ebuild
+++ b/app-sci/snac/snac-0.3.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/snac/snac-0.3.ebuild,v 1.2 2002/12/07 03:25:29 george Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snac/snac-0.3.ebuild,v 1.3 2002/12/18 14:40:44 vapier Exp $
-IUSE=""
-
-S="${WORKDIR}/${P}"
DESCRIPTION="SNAC's a Neat Algebraic Calculator."
SRC_URI="http://snac.seul.org/${P}.tar.gz"
-HOMEPAGE="http://snac.seul.org"
+HOMEPAGE="http://snac.seul.org/"
SLOT="0"
LICENSE="GPL-2"
@@ -25,13 +22,11 @@ src_unpack() {
}
src_compile() {
- econf ||die "econf failed"
-
+ econf
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- # Install documentation.
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS
}
diff --git a/app-sci/systemc/systemc-2.0.1.ebuild b/app-sci/systemc/systemc-2.0.1.ebuild
index d7c025429845..fdc1d2d46515 100644
--- a/app-sci/systemc/systemc-2.0.1.ebuild
+++ b/app-sci/systemc/systemc-2.0.1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/systemc/systemc-2.0.1.ebuild,v 1.1 2002/12/06 19:59:00 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/systemc/systemc-2.0.1.ebuild,v 1.2 2002/12/18 14:43:08 vapier Exp $
-IUSE=""
-
-DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design."
-HOMEPAGE="http://www.systemc.org"
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="http://www.systemc.org/"
SRC_URI="systemc-2.0.1.tgz"
SLOT="0"
@@ -20,7 +18,7 @@ dyn_fetch() {
einfo "${PN} developes require end-users to accept their license agreement"
einfo "by registering on their site (http://www.systemc.org)"
einfo "Please download ${P} manually and place it in ${DISTDIR}"
- exit 1
+ die
fi
}
@@ -33,7 +31,7 @@ src_unpack() {
}
src_compile() {
- econf || die
+ econf
emake || die
cd ${S}/src/systemc/kernel
ar cru ../../../src/libsystemc.a sc_attribute.o sc_cor_fiber.o sc_cor_qt.o sc_event.o sc_kernel_ids.o sc_lambda.o sc_main.o sc_module.o sc_module_name.o sc_module_registry.o sc_name_gen.o sc_object.o sc_object_manager.o sc_process_int.o sc_runnable.o sc_sensitive.o sc_simcontext.o sc_time.o sc_ver.o sc_wait.o sc_wait_cthread.o
@@ -53,7 +51,7 @@ src_compile() {
ar cru ../../../src/libsystemc.a sc_exception.o sc_hash.o sc_list.o sc_mempool.o sc_pq.o sc_report.o sc_report_handler.o sc_stop_here.o sc_string.o sc_utils_ids.o sc_vector.o
}
-src_install () {
+src_install() {
cd ${S}/src
dolib.a libsystemc.a
dodir /usr/include/systemc
@@ -69,7 +67,3 @@ src_install () {
sed -e "s:LIBDIR =:#LIBDIR =:g" Makefile.defs.orig > Makefile.defs.1
sed -e "s:\$(EXE).*:\$(EXE)\: \$(OBJS):g" Makefile.defs.1 > Makefile.defs
}
-
-
-
-