summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-14 18:55:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-14 18:55:09 +0000
commit18f529d7db9260a808bf2be5d36b0548b0a25d31 (patch)
tree7a78dc407c3aea9fd717fe5d95e16f2d3dfa6bde /app-shells/bash/bash-2.05b-r11.ebuild
parentstable on amd64 and ppc (diff)
downloadhistorical-18f529d7db9260a808bf2be5d36b0548b0a25d31.tar.gz
historical-18f529d7db9260a808bf2be5d36b0548b0a25d31.tar.bz2
historical-18f529d7db9260a808bf2be5d36b0548b0a25d31.zip
dont use gcc eclass anymore
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'app-shells/bash/bash-2.05b-r11.ebuild')
-rw-r--r--app-shells/bash/bash-2.05b-r11.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/app-shells/bash/bash-2.05b-r11.ebuild b/app-shells/bash/bash-2.05b-r11.ebuild
index efb101e13fb9..a123c90ffdff 100644
--- a/app-shells/bash/bash-2.05b-r11.ebuild
+++ b/app-shells/bash/bash-2.05b-r11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r11.ebuild,v 1.5 2005/01/01 15:56:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r11.ebuild,v 1.6 2005/05/14 18:55:09 vapier Exp $
-inherit eutils flag-o-matic gnuconfig gcc
+inherit eutils flag-o-matic toolchain-funcs
# Official patches
PLEVEL="x002 x003 x004 x005 x006 x007"
@@ -65,8 +65,6 @@ src_unpack() {
# especially easy with 2.6 kernels.
echo '#define PGRP_PIPE 1' >> config-bot.h
- gnuconfig_update
-
sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
@@ -89,7 +87,7 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
echo 'int main(){}' > ${T}/term-test.c
- if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ if ! $(tc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
export bash_cv_termcap_lib=gnutermcap
else
export bash_cv_termcap_lib=libcurses