summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-31 03:58:31 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-31 03:58:31 +0000
commitcf3e7007229b0c7560490e5d276e7585181545fd (patch)
tree309c05c9de60abde4ee0509bc5cd5b124ba5a95d /app-shells/scsh/scsh-0.6.7.ebuild
parentRemove old ebuilds; Hard mask amd64 -- there is no 64-bit support for now. (diff)
downloadhistorical-cf3e7007229b0c7560490e5d276e7585181545fd.tar.gz
historical-cf3e7007229b0c7560490e5d276e7585181545fd.tar.bz2
historical-cf3e7007229b0c7560490e5d276e7585181545fd.zip
New upstream version; Remove old ebuilds; Hard mask amd64 -- there is no 64-bit support for now.
Package-Manager: portage-2.1.1_pre5-r3
Diffstat (limited to 'app-shells/scsh/scsh-0.6.7.ebuild')
-rw-r--r--app-shells/scsh/scsh-0.6.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-shells/scsh/scsh-0.6.7.ebuild b/app-shells/scsh/scsh-0.6.7.ebuild
new file mode 100644
index 000000000000..ee4ea9b1b655
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.7.ebuild,v 1.1 2006/08/31 03:58:31 mkennedy Exp $
+
+inherit eutils scsh
+
+MV="${PV%*.*}"
+
+DESCRIPTION="Unix shell embedded in Scheme"
+HOMEPAGE="http://www.scsh.net/"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/${MV}/${P}.tar.gz"
+LICENSE="as-is BSD"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+
+src_unpack() {
+ # SCSH_LIB_DIRS='$SCSH_SCSH_PATH'
+ set_layout
+ set_path_variables
+ unpack ${A}
+ cd ${S}
+ if ! use scsh; then
+ epatch ${FILESDIR}/0.6.6-Makefile.in-doc-dir-gentoo.patch || die
+ fi
+}
+
+src_compile() {
+ scsh_conf="--prefix=/usr
+ --libdir=/usr/$(get_libdir)
+ --includedir=/usr/include
+ --with-lib-dirs-list=$(scsh_scsh_path)"
+ econf ${scsh_conf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodir /etc/env.d
+ cat >${D}/etc/env.d/50scsh <<EOF
+SCSH_LIB_DIRS='${SCSH_LIB_DIRS}'
+EOF
+}