summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-01-03 09:36:11 +0000
committerTorsten Veller <tove@gentoo.org>2011-01-03 09:36:11 +0000
commit68958b86e7279d250ab0eedcbf4456e3ccf3bbd3 (patch)
tree5f22f7eb716806655040ca54668961669467bbcb /app-shells/zsh/files
parentVersion bump (#349291) (diff)
downloadhistorical-68958b86e7279d250ab0eedcbf4456e3ccf3bbd3.tar.gz
historical-68958b86e7279d250ab0eedcbf4456e3ccf3bbd3.tar.bz2
historical-68958b86e7279d250ab0eedcbf4456e3ccf3bbd3.zip
Cleanup
Package-Manager: portage-2.2.0_alpha10/cvs/Linux x86_64
Diffstat (limited to 'app-shells/zsh/files')
-rw-r--r--app-shells/zsh/files/prompt_gentoo_setup45
-rw-r--r--app-shells/zsh/files/zprofile41
-rw-r--r--app-shells/zsh/files/zsh-4.3.4-configure-changequote.patch25
-rw-r--r--app-shells/zsh/files/zsh-4.3.4-mkmakemod.patch15
4 files changed, 0 insertions, 126 deletions
diff --git a/app-shells/zsh/files/prompt_gentoo_setup b/app-shells/zsh/files/prompt_gentoo_setup
deleted file mode 100644
index abc3ceb154c5..000000000000
--- a/app-shells/zsh/files/prompt_gentoo_setup
+++ /dev/null
@@ -1,45 +0,0 @@
-# gentoo prompt theme
-
-prompt_gentoo_help () {
- cat <<'EOF'
-This prompt is color-scheme-able. You can invoke it thus:
-
- prompt gentoo [<promptcolor> [<usercolor> [<rootcolor>]]]
-
-EOF
-}
-
-prompt_gentoo_setup () {
- prompt_gentoo_prompt=${1:-'blue'}
- prompt_gentoo_user=${2:-'green'}
- prompt_gentoo_root=${3:-'red'}
-
- if [ "$USER" = 'root' ]
- then
- base_prompt="%{$fg_bold[$prompt_gentoo_root]%}%m%{$reset_color%} "
- else
- base_prompt="%{$fg_bold[$prompt_gentoo_user]%}%n@%m%{$reset_color%} "
- fi
- post_prompt="%{$reset_color%}"
-
- local color="%{*}"
- base_prompt_no_color="${(S)base_prompt//${~color}/}"
- post_prompt_no_color="${(S)post_prompt//${~color}/}"
-
- setopt noxtrace localoptions
- local base_prompt_expanded_no_color base_prompt_etc
- local prompt_length space_left
-
- base_prompt_expanded_no_color=$(print -P "$base_prompt_no_color")
- base_prompt_etc=$(print -P "$base_prompt%(4~|...|)%3~")
- prompt_length=${#base_prompt_etc}
- path_prompt="%{$fg_bold[$prompt_gentoo_prompt]%}%1~"
- PS1="$base_prompt$path_prompt %# $post_prompt"
- PS2="$base_prompt$path_prompt %_> $post_prompt"
- PS3="$base_prompt$path_prompt ?# $post_prompt"
-
- precmd () { }
- preexec () { }
-}
-
-prompt_gentoo_setup "$@"
diff --git a/app-shells/zsh/files/zprofile b/app-shells/zsh/files/zprofile
deleted file mode 100644
index 73a7cf83d0f4..000000000000
--- a/app-shells/zsh/files/zprofile
+++ /dev/null
@@ -1,41 +0,0 @@
-# /etc/zsh/zprofile
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/files/zprofile,v 1.5 2008/05/23 12:02:51 tove Exp $
-
-# Load environment settings from profile.env, which is created by
-# env-update from the files in /etc/env.d
-if [ -e /etc/profile.env ] ; then
- . /etc/profile.env
-fi
-
-# You should override these in your ~/.zprofile (or equivalent) for per-user
-# settings. For system defaults, you can add a new file in /etc/profile.d/.
-export EDITOR=${EDITOR:-/bin/nano}
-export PAGER=${PAGER:-/usr/bin/less}
-
-# 077 would be more secure, but 022 is generally quite realistic
-umask 022
-
-# Set up PATH depending on whether we're root or a normal user.
-# There's no real reason to exclude sbin paths from the normal user,
-# but it can make tab-completion easier when they aren't in the
-# user's PATH to pollute the executable namespace.
-#
-# It is intentional in the following line to use || instead of -o.
-# This way the evaluation can be short-circuited and calling whoami is
-# avoided.
-if [ "$EUID" = "0" ] || [ "$USER" = "root" ] ; then
- PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:${ROOTPATH}"
-else
- PATH="/usr/local/bin:/usr/bin:/bin:${PATH}"
-fi
-export PATH
-unset ROOTPATH
-
-shopts=$-
-setopt nullglob
-for sh in /etc/profile.d/*.sh ; do
- [ -r "$sh" ] && . "$sh"
-done
-unsetopt nullglob
-set -$shopts
-unset sh shopts
diff --git a/app-shells/zsh/files/zsh-4.3.4-configure-changequote.patch b/app-shells/zsh/files/zsh-4.3.4-configure-changequote.patch
deleted file mode 100644
index 2abad2462ee2..000000000000
--- a/app-shells/zsh/files/zsh-4.3.4-configure-changequote.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -ur a/configure.ac b/configure.ac
---- a/configure.ac 2007-01-05 13:58:04 +0000
-+++ b/configure.ac 2007-08-16 09:17:29 +0100
-@@ -2249,6 +2249,10 @@
- zsh_cv_sys_elf=yes,
- zsh_cv_sys_elf=no,
- zsh_cv_sys_elf=yes)])
-+
-+ # We use [0-9]* in case statements, so need to change quoting
-+ changequote(, )
-+
- DL_EXT="${DL_EXT=so}"
- if test x$zsh_cv_sys_elf = xyes; then
- case "$host" in
-@@ -2352,6 +2356,10 @@
- esac
- ;;
- esac
-+
-+ # Done with our shell code, so restore autotools quoting
-+ changequote([, ])
-+
- AC_CACHE_CHECK(if your dlsym() needs a leading underscore,
- zsh_cv_func_dlsym_needs_underscore,
- [echo failed >conftestval && cat >conftest.c <<EOM
diff --git a/app-shells/zsh/files/zsh-4.3.4-mkmakemod.patch b/app-shells/zsh/files/zsh-4.3.4-mkmakemod.patch
deleted file mode 100644
index f8dea0397a9b..000000000000
--- a/app-shells/zsh/files/zsh-4.3.4-mkmakemod.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-bug #254348
---- a/Src/mkmakemod.sh
-+++ b/Src/mkmakemod.sh
-@@ -111,10 +111,7 @@
- sed -e '/^#/d' -e 's/ .*/ /' -e 's/^name=/ /'`"
- module_list="${bin_mods}${dyn_mods}"
-
-- # check 2.13, 2.50, and 2.60 syntaxes
-- if grep '%@D@%D%' config.status >/dev/null ||
-- grep ',@D@,D,' config.status >/dev/null ||
-- grep ',@D@,|#_!!_#|D,' config.status >/dev/null; then
-+ if grep '^#define DYNAMIC ' config.h >/dev/null; then
- is_dynamic=true
- else
- is_dynamic=false