summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-10 02:00:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-10 02:00:54 +0000
commit35f399cae44e9aa6e93ac2fc046995f7d97ac853 (patch)
treeace59b2bdc14dd0610791d32a4db16f2b6b5738b /app-shells
parentmake sure to source right env (diff)
downloadhistorical-35f399cae44e9aa6e93ac2fc046995f7d97ac853.tar.gz
historical-35f399cae44e9aa6e93ac2fc046995f7d97ac853.tar.bz2
historical-35f399cae44e9aa6e93ac2fc046995f7d97ac853.zip
and setup portage env correctly
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sandboxshell/Manifest2
-rw-r--r--app-shells/sandboxshell/files/sandboxshell.conf9
2 files changed, 7 insertions, 4 deletions
diff --git a/app-shells/sandboxshell/Manifest b/app-shells/sandboxshell/Manifest
index a69f2e9f06c4..6e9c69714fae 100644
--- a/app-shells/sandboxshell/Manifest
+++ b/app-shells/sandboxshell/Manifest
@@ -1,5 +1,5 @@
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-sandboxshell-0.1 0
MD5 540f05af4f7a2f11076c74fab84d6fae files/sandboxshell 1280
-MD5 5312742635c52fdd563b8f5b8181afca files/sandboxshell.conf 1555
+MD5 efdff08ba9889ecf839b72ef3f3df410 files/sandboxshell.conf 1646
MD5 e9b12ed968232649b988e6240b669d67 sandboxshell-0.1.ebuild 645
MD5 13d32120b2140672efccbbdbba87e66e ChangeLog 356
diff --git a/app-shells/sandboxshell/files/sandboxshell.conf b/app-shells/sandboxshell/files/sandboxshell.conf
index d64150566dff..e9e4440894dc 100644
--- a/app-shells/sandboxshell/files/sandboxshell.conf
+++ b/app-shells/sandboxshell/files/sandboxshell.conf
@@ -1,7 +1,7 @@
#!/bin/bash
# Written by vapier@gentoo.org
# public-domain code ... z0r ...
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.2 2003/07/10 01:56:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.3 2003/07/10 02:00:45 vapier Exp $
source /etc/profile
@@ -25,10 +25,13 @@ if [ "${PWD:0:${#sbs_pdir}}" == "${sbs_pdir}" ] ; then
sbs_tmpenvfile=${sbs_pdir}${sbs_bdir}/temp/environment
if [ -e "${sbs_tmpenvfile}" ] ; then
echo "Found environment at ${sbs_tmpenvfile}"
- printf " * Would you like to load the environment? "
+ printf " * Would you like to enter the portage environment ? "
read env
sbs_PREPWD=${PWD}
- [ "${env}" == "y" ] && source ${sbs_tmpenvfile} 2> /dev/null
+ if [ "${env}" == "y" ] ; then
+ source ${sbs_tmpenvfile} 2> /dev/null
+ export SANDBOX_WRITE="${SANDBOX_WRITE}:${sbs_pdir}${sbs_bdir}"
+ fi
PWD=${sbs_PREPWD}
fi
fi