summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-10-19 13:03:37 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-10-19 13:03:37 +0000
commit4319badc70c869ed19e1d87432606896478882a7 (patch)
tree946c84423668f0e97eb008325c5f8e1036b491cf /app-shells
parentstable on x86 (diff)
downloadhistorical-4319badc70c869ed19e1d87432606896478882a7.tar.gz
historical-4319badc70c869ed19e1d87432606896478882a7.tar.bz2
historical-4319badc70c869ed19e1d87432606896478882a7.zip
Version bump; includes new version of gentoo-bashcomp as well (new equery completion available which closes #55687).
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/Manifest10
-rw-r--r--app-shells/bash-completion/bash-completion-20041017.ebuild74
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200410172
4 files changed, 90 insertions, 5 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index c230b5dbfec0..738f9f908b88 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.71 2004/10/12 00:00:49 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.72 2004/10/19 13:03:37 ka0ttic Exp $
+
+*bash-completion-20041017 (19 Oct 2004)
+
+ 19 Oct 2004; Aaron Walker <ka0ttic@gentoo.org>
+ +bash-completion-20041017.ebuild:
+ Version bump; includes new version of gentoo-bashcomp as well (new equery
+ completion available which closes #55687).
*bash-completion-20040711 (11 Oct 2004)
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index cf464d4603fa..4f7e4f395e34 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -5,18 +5,20 @@ MD5 4339bf4a7a49600362a4acb22e2077b1 bash-completion-20040711.ebuild 2093
MD5 115faf601395c07a603403509d2e6e25 bash-completion-20040526.ebuild 1918
MD5 cc5ea05a3deb5a269cb42964b943b230 bash-completion-20040704.ebuild 2091
MD5 0c67559393ee08d7446bc1fbf4420985 bash-completion-20040704-r1.ebuild 2086
-MD5 625025f1fa5700bf6bf460f4fe219b6b ChangeLog 10137
+MD5 a232be64db541ba673dabc079c8948f8 ChangeLog 10385
MD5 00e8cae3d9ece63e4be61f4a2b3afd5e metadata.xml 930
+MD5 5263f67341f132cde692e17c1c7c2e06 bash-completion-20041017.ebuild 2094
MD5 4bbcbd54e5ec94b050417205572e13e9 files/gentoo.completion-20040526 16023
MD5 ff208a2c09a302be5db88edf519a4086 files/bash-completion 626
MD5 1c828ed53387932b8ed971aafa179875 files/digest-bash-completion-20040526 76
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704 151
MD5 73c3177da25971c1db7bb6482b5d1580 files/digest-bash-completion-20040711 151
+MD5 236fd9c517ac5642cae8df109dbaf9f6 files/digest-bash-completion-20041017 152
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704-r1 151
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBax8bEZCkKN40op4RAugzAJ4y9bTZoxwpR0y32D+6/aP8QKMt8gCfcVHC
-4U1XzElKgQvwkkOUzt/4stA=
-=zR1C
+iD8DBQFBdRCyEZCkKN40op4RAkSYAJ4+gleB/A5IG6a/jL/VdH+toQfEFACeMHFi
+exnDXrKA37PBFkV6a/HrisY=
+=tPG2
-----END PGP SIGNATURE-----
diff --git a/app-shells/bash-completion/bash-completion-20041017.ebuild b/app-shells/bash-completion/bash-completion-20041017.ebuild
new file mode 100644
index 000000000000..aa30d41444a7
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20041017.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20041017.ebuild,v 1.1 2004/10/19 13:03:37 ka0ttic Exp $
+
+GENCOMP_VERS="1.0_beta2"
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
+ mirror://sourceforge/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~s390"
+IUSE=""
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+RDEPEND=">=app-shells/bash-2.05a"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /usr/share/bash-completion
+ doins contrib/*
+
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion
+
+ dodoc Changelog README
+
+ cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+ insinto /etc/bash_completion.d
+ doins src/gentoo
+
+ docinto gentoo
+ dodoc AUTHORS NEWS TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+
+ if [ -f ${ROOT}/etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ fi
+
+ local bcfile moved
+ for bcfile in ${ROOT}/etc/bash_completion.d/{unrar,harbour,isql,larch,lilypond,p4,ri}
+ do
+
+ [ -f "${bcfile}" -a ! -L "${bcfile}" ] && moved="${bcfile##*/} ${moved}"
+ done
+
+ if [ -n "${moved}" ]
+ then
+ echo
+ ewarn "The contrib files: ${moved}"
+ ewarn "have been moved to /usr/share/bash-completion. Please DELETE"
+ ewarn "those old files in /etc/bash_completion.d and create symlinks."
+ fi
+ echo
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20041017 b/app-shells/bash-completion/files/digest-bash-completion-20041017
new file mode 100644
index 000000000000..192b9cf05a2b
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20041017
@@ -0,0 +1,2 @@
+MD5 3fd0836127d01606a9dc4262f3e2e1fb bash-completion-20041017.tar.bz2 86227
+MD5 1d4fb21337ed341334188fed97fa0745 gentoo-bashcomp-1.0_beta2.tar.gz 15025