summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-08-29 15:44:13 +0000
committerTilman Klar <phoenix@gentoo.org>2002-08-29 15:44:13 +0000
commitb54c5b859becde574fb92fc8ff94bbdcc40a5ddb (patch)
tree5e76caa0c6cbfd8da5ebf720a0b020153f17147c /app-shells
parentRemoved motif-related build components as motif is not supported. (diff)
downloadhistorical-b54c5b859becde574fb92fc8ff94bbdcc40a5ddb.tar.gz
historical-b54c5b859becde574fb92fc8ff94bbdcc40a5ddb.tar.bz2
historical-b54c5b859becde574fb92fc8ff94bbdcc40a5ddb.zip
Bumped to new revision to fix a sandbox violation.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog14
-rw-r--r--app-shells/zsh/files/digest-zsh-4.0.6-r11
-rw-r--r--app-shells/zsh/zsh-4.0.6-r1.ebuild46
3 files changed, 57 insertions, 4 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 983096412952..5901217ec627 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,15 +1,21 @@
# ChangeLog for app-shells/zsh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.9 2002/08/24 10:01:27 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.10 2002/08/29 15:44:13 phoenix Exp $
-*zsh-4.0.6 (24 Aug 2002)
+*zsh-4.0.6-r1 (29 Aug 2002)
- 24 Aug 2002; Sascha Schwabbauer <cybersystem@gentoo.org> zsh-4.0.6.ebuild :
+ 19 Aug 2002; phoen][x <phoenixk@gentoo.org> zsh-4.0.6-r1.ebuild
+ files/digest-zsh-4.0.6-r1 :
+
+ Fixed a sandbox violation. Check bug 6780 for further details.
- Disabled make check because it violates the sandbox.
*zsh-4.0.6 (19 Aug 2002)
+ 24 Aug 2002; Sascha Schwabbauer <cybersystem@gentoo.org> zsh-4.0.6.ebuild :
+
+ Disabled make check because it violates the sandbox.
+
19 Aug 2002; phoen][x <phoenixk@gentoo.org> zsh-4.0.6.ebuild
files/digest-zsh-4.0.6 :
diff --git a/app-shells/zsh/files/digest-zsh-4.0.6-r1 b/app-shells/zsh/files/digest-zsh-4.0.6-r1
new file mode 100644
index 000000000000..dba4516cff6d
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.0.6-r1
@@ -0,0 +1 @@
+MD5 6a86da9120e97ebe03afd6a51f717c0f zsh-4.0.6.tar.gz 2146169
diff --git a/app-shells/zsh/zsh-4.0.6-r1.ebuild b/app-shells/zsh/zsh-4.0.6-r1.ebuild
new file mode 100644
index 000000000000..0c830cfbc74b
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.6-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r1.ebuild,v 1.1 2002/08/29 15:44:13 phoenix Exp $
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.gz"
+HOMEPAGE="www.zsh.org/"
+SLOT="0"
+LICENSE="ZSH"
+
+DEPEND=">=sys-libs/ncurses-5.1"
+
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/lib \
+ --enable-maildir-support \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zshlogin=/etc/zsh/zshlogin \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs || die "configure failed"
+ # emake still b0rks
+ make || die "make failed"
+ #make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh/${PV}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ dodoc ChangeLog META-FAQ README INSTALL LICENCE config.modules
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+ dodir /etc/zsh
+ cp ${S}/StartupFiles/z* ${D}/etc/zsh
+}