summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-14 09:29:11 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-14 09:29:11 +0000
commitb557106083d528b430936596e2a5a759349bf990 (patch)
treeb09e818be987f64db674f0ef7213156afef289eb /app-text/apvlv/apvlv-0.1.2.ebuild
parentAn intermittent explosion due to memory corruption was identified and patched... (diff)
downloadhistorical-b557106083d528b430936596e2a5a759349bf990.tar.gz
historical-b557106083d528b430936596e2a5a759349bf990.tar.bz2
historical-b557106083d528b430936596e2a5a759349bf990.zip
Version bump. Use new github site and update to EAPI 4.
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'app-text/apvlv/apvlv-0.1.2.ebuild')
-rw-r--r--app-text/apvlv/apvlv-0.1.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/apvlv/apvlv-0.1.2.ebuild b/app-text/apvlv/apvlv-0.1.2.ebuild
new file mode 100644
index 000000000000..26648ce1b31a
--- /dev/null
+++ b/app-text/apvlv/apvlv-0.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/apvlv-0.1.2.ebuild,v 1.1 2011/07/14 09:29:11 radhermit Exp $
+
+EAPI=4
+
+inherit eutils cmake-utils
+
+MY_P="${P}-Source"
+DESCRIPTION="Alf's PDF Viewer Like Vim"
+HOMEPAGE="http://naihe2010.github.com/apvlv/"
+SRC_URI="https://github.com/downloads/naihe2010/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug djvu"
+
+RDEPEND=">=x11-libs/gtk+-2.10.4:2
+ >=app-text/poppler-0.12.3-r3[cairo]
+ djvu? ( app-text/djvu )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug #349979
+ EPATCH_OPTS="-l"
+ has_version ">=app-text/poppler-0.15.0" && epatch "${FILESDIR}"/${PN}-0.1.0-poppler-0.16.patch
+
+ # Remove prefixes so it works with the cmake-utils eclass
+ sed -i -e "s:APVLV_::" CMakeLists.txt src/CMakeLists.txt || die
+
+ # Don't install tex file
+ sed -i -e "s:Startup.tex::" CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DSYSCONFDIR=/etc/${PN}
+ -DDOCDIR=/usr/share/${PN}
+ -DMANDIR=/usr/share/man
+ -DWITH_UMD=OFF
+ $(cmake-utils_use_enable debug)
+ $(cmake-utils_use_with djvu)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS NEWS README THANKS TODO
+ newicon icons/pdf.png ${PN}.png
+ make_desktop_entry ${PN} "Alf's PDF Viewer Like Vim" ${PN} "Office;Viewer"
+}