summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-06-09 20:40:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-06-09 20:40:32 +0000
commitaaa891685b80d0b67d4e3921b754a4f8895d0940 (patch)
treedb055451c3c425534dd5b52b42516cb850a997a6 /app-text/aspell
parentAdded ~sparc, #53446 (diff)
downloadhistorical-aaa891685b80d0b67d4e3921b754a4f8895d0940.tar.gz
historical-aaa891685b80d0b67d4e3921b754a4f8895d0940.tar.bz2
historical-aaa891685b80d0b67d4e3921b754a4f8895d0940.zip
Apply a patch to fix the buffer overflow reported in: http://www.securityfocus.com/archive/1/365479. This should close bug #53389 by: Florian Schilhabel <florian.schilhabel@gmx.net>. Other arches need to push this to stable
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog11
-rw-r--r--app-text/aspell/Manifest7
-rw-r--r--app-text/aspell/aspell-0.50.5-r1.ebuild69
-rw-r--r--app-text/aspell/files/aspell-buffer-fix.patch50
-rw-r--r--app-text/aspell/files/digest-aspell-0.50.5-r11
5 files changed, 135 insertions, 3 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index 59d5b377a20d..c3babccb629c 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.38 2004/06/06 21:31:12 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.39 2004/06/09 20:40:32 seemant Exp $
+
+*aspell-0.50.5-r1 (09 Jun 2004)
+
+ 09 Jun 2004; Seemant Kulleen <seemant@gentoo.org>
+ +files/aspell-buffer-fix.patch, +aspell-0.50.5-r1.ebuild:
+ Apply a patch to fix the buffer overflow reported in:
+ http://www.securityfocus.com/archive/1/365479. This should close bug #53389
+ by: Florian Schilhabel <florian.schilhabel@gmx.net>. Other arches need to push
+ this to stable
06 Jun 2004; Travis Tilley <lv@gentoo.org> aspell-0.50.5.ebuild:
stable on amd64 for gcc 3.4 fix
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index d2ec3d258cd3..490465fa8840 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,10 +1,13 @@
MD5 e2f9302a80a1c9d33d7b5f069b544caa aspell-0.50.3.ebuild 1547
-MD5 b305e9f85ff2d7d7d6edfc9eb7c6f28d aspell-0.50.5.ebuild 1602
+MD5 7da455f49e6d65bf05bfffa917156f90 aspell-0.50.5.ebuild 1601
+MD5 e2047f145ddf3ccf658fea8707147008 aspell-0.50.5-r1.ebuild 1697
MD5 18093407abb990118dc90124dcbe3201 aspell-0.50.4.1.ebuild 1523
-MD5 5dd4f60312d2cd2d0561d0931ad92a3c ChangeLog 6969
+MD5 31ada9f93b0598b5938a8f9b41a63105 ChangeLog 7351
MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
MD5 b266f4134f47fc1c8152daa6d4276f26 files/digest-aspell-0.50.3 65
MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5 66
MD5 9d6c4f620a419b9ef08ddaf327adff75 files/digest-aspell-0.50.4.1 67
MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
+MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5-r1 66
+MD5 49ee9111cd812ddb089fc5592780ac13 files/aspell-buffer-fix.patch 1094
MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
diff --git a/app-text/aspell/aspell-0.50.5-r1.ebuild b/app-text/aspell/aspell-0.50.5-r1.ebuild
new file mode 100644
index 000000000000..45de411c700f
--- /dev/null
+++ b/app-text/aspell/aspell-0.50.5-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5-r1.ebuild,v 1.1 2004/06/09 20:40:32 seemant Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="http://aspell.net/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~mips alpha arm hppa amd64 ~ia64 s390"
+IUSE="gpm"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
+
+pkg_setup() {
+ if [ ${ARCH} = "ppc" ] ; then
+ CXXFLAGS="-O2 -fsigned-char"
+ CFLAGS=${CXXFLAGS}
+ fi
+ use gpm && LDFLAGS="-lgpm"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-buffer-fix.patch
+}
+
+src_compile() {
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+}
diff --git a/app-text/aspell/files/aspell-buffer-fix.patch b/app-text/aspell/files/aspell-buffer-fix.patch
new file mode 100644
index 000000000000..cf43e7b9d56c
--- /dev/null
+++ b/app-text/aspell/files/aspell-buffer-fix.patch
@@ -0,0 +1,50 @@
+diff -urN aspell-0.50.5.orig/prog/compress.c aspell-0.50.5/prog/compress.c
+--- aspell-0.50.5.orig/prog/compress.c 2002-08-31 11:51:11.000000000 -0700
++++ aspell-0.50.5/prog/compress.c 2004-06-09 13:11:46.000000000 -0700
+@@ -28,6 +28,9 @@
+
+ #endif
+
++int count;
++
++
+ void usage ()
+ {
+ fputs("Compresses or uncompresses sorted word lists.\n" , stderr);
+@@ -47,6 +50,7 @@
+ *w++ = (char)(c);
+ } while (c = getc(in), c != EOF && c > 32);
+ *w = '\0';
++ count++;
+ ungetc(c, in);
+ if (c == EOF) return 0;
+ else return 1;
+@@ -69,6 +73,7 @@
+
+ SETBIN (stdout);
+
++ while (count < 256) {
+ while (get_word(stdin, cur)) {
+ int i = 0;
+ /* get the length of the prefix */
+@@ -85,6 +90,7 @@
+ prev = s2; cur = s1;
+ }
+ }
++ }
+ return 0;
+
+ } else if (argv[1][0] == 'd') {
+@@ -100,8 +106,11 @@
+ if (i == 0)
+ i = getc(stdin);
+ --i;
+- while ((c = getc(stdin)) > 32)
++ while ((c = getc(stdin)) > 32 && count < 256) {
+ cur[i++] = (char)c;
++ count++;
++ }
++
+ cur[i] = '\0';
+ fputs(cur, stdout);
+ putc('\n', stdout);
diff --git a/app-text/aspell/files/digest-aspell-0.50.5-r1 b/app-text/aspell/files/digest-aspell-0.50.5-r1
new file mode 100644
index 000000000000..d497ea8286ff
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.50.5-r1
@@ -0,0 +1 @@
+MD5 14403d2ea5ded5d3fc9bb259bf65aab5 aspell-0.50.5.tar.gz 1016586