summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-07-31 16:07:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-07-31 16:07:27 +0000
commit362b5cfbc8e842dbbdda94319031832bd041e9dd (patch)
tree21fac10d83e06ab4aed205f02edd1a721d95e1e2 /app-text/chasen/chasen-2.4.4.ebuild
parentVersion bumped. Added cjk herd to metadata.xml. (diff)
downloadhistorical-362b5cfbc8e842dbbdda94319031832bd041e9dd.tar.gz
historical-362b5cfbc8e842dbbdda94319031832bd041e9dd.tar.bz2
historical-362b5cfbc8e842dbbdda94319031832bd041e9dd.zip
Version bumped.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-text/chasen/chasen-2.4.4.ebuild')
-rw-r--r--app-text/chasen/chasen-2.4.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/chasen/chasen-2.4.4.ebuild b/app-text/chasen/chasen-2.4.4.ebuild
new file mode 100644
index 000000000000..de37af29bb58
--- /dev/null
+++ b/app-text/chasen/chasen-2.4.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chasen/chasen-2.4.4.ebuild,v 1.1 2008/07/31 16:07:27 matsuu Exp $
+
+inherit perl-module
+
+DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
+HOMEPAGE="http://chasen-legacy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp//chasen-legacy/32224/${P}.tar.gz"
+
+LICENSE="chasen"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl"
+
+DEPEND=">=dev-libs/darts-0.32"
+RDEPEND="${DEPEND}
+ perl? ( !dev-perl/Text-ChaSen )"
+PDEPEND=">=app-dicts/ipadic-2.7.0"
+
+src_compile() {
+ econf || die
+ emake || die
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_compile
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_install
+ newdoc README README.perl
+ fi
+}