summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-26 11:50:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-26 11:50:50 +0000
commitb0cb18bbe1f9e9bda767b7686b8f99cba7b9f434 (patch)
tree19a2563e87a3c08890cdebbb5077cc09db30d844 /app-text/chm2pdf/chm2pdf-0.9.1.ebuild
parentVersion bump (diff)
downloadhistorical-b0cb18bbe1f9e9bda767b7686b8f99cba7b9f434.tar.gz
historical-b0cb18bbe1f9e9bda767b7686b8f99cba7b9f434.tar.bz2
historical-b0cb18bbe1f9e9bda767b7686b8f99cba7b9f434.zip
Initial import of chm2pdf program. Fixes bug #205208
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-text/chm2pdf/chm2pdf-0.9.1.ebuild')
-rw-r--r--app-text/chm2pdf/chm2pdf-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/chm2pdf/chm2pdf-0.9.1.ebuild b/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
new file mode 100644
index 000000000000..a2c5a2f5f9c7
--- /dev/null
+++ b/app-text/chm2pdf/chm2pdf-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/chm2pdf-0.9.1.ebuild,v 1.1 2009/02/26 11:50:49 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A script that converts a CHM file into a single PDF file."
+HOMEPAGE="http://code.google.com/p/chm2pdf/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pychm
+ app-text/htmldoc
+ dev-libs/chmlib
+ dev-lang/python"
+
+src_prepare(){
+ epatch "${FILESDIR}/tempdir.patch"
+}
+
+src_install() {
+ dobin ${PN} || die "failed to create executable"
+ dodoc README || die "dodoc failed"
+}