summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-09-15 14:19:06 +0000
committerMike Gardiner <obz@gentoo.org>2003-09-15 14:19:06 +0000
commit0ef01d59f2c16913ed791ad1f5c0b9368b0e8c6a (patch)
tree746de63cab3b5204662ee2749be2a6d131affbc6 /app-text/djvu/djvu-3.5.12.ebuild
parentrepoman violation (diff)
downloadhistorical-0ef01d59f2c16913ed791ad1f5c0b9368b0e8c6a.tar.gz
historical-0ef01d59f2c16913ed791ad1f5c0b9368b0e8c6a.tar.bz2
historical-0ef01d59f2c16913ed791ad1f5c0b9368b0e8c6a.zip
Added qt use variable
Diffstat (limited to 'app-text/djvu/djvu-3.5.12.ebuild')
-rw-r--r--app-text/djvu/djvu-3.5.12.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-text/djvu/djvu-3.5.12.ebuild b/app-text/djvu/djvu-3.5.12.ebuild
index 42911d26bbb8..4253a942ac8d 100644
--- a/app-text/djvu/djvu-3.5.12.ebuild
+++ b/app-text/djvu/djvu-3.5.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.12.ebuild,v 1.1 2003/09/13 08:04:43 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.12.ebuild,v 1.2 2003/09/15 14:18:55 obz Exp $
-inherit nsplugins flag-o-matic
+inherit nsplugins
MY_P="${PN}libre-${PV}"
@@ -13,10 +13,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc "
-IUSE="xml"
+IUSE="xml qt"
-DEPEND=">=x11-libs/qt-2.3
- >=media-libs/jpeg-6b-r2"
+DEPEND=">=media-libs/jpeg-6b-r2
+ qt? ( >=x11-libs/qt-2.3 )"
S=${WORKDIR}/${MY_P}
@@ -26,11 +26,14 @@ src_compile() {
# <obz@gentoo.org>
replace-flags "-march=pentium4" "-march=pentium3"
- local xmlconf=""
+ local myconf=""
use xml \
- && xmlconf="${xmlconf} --enable-xmltools"
+ && myconf="${myconf} --enable-xmltools"
+ use qt \
+ || myconf="${myconf} --without-qt"
econf ${myconf} || die
+ make depend
emake || die
}