summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <tanderson@gentoo.org>2009-03-07 14:17:29 +0000
committerThomas Anderson <tanderson@gentoo.org>2009-03-07 14:17:29 +0000
commite97c75096660077af96d7d6ef9f6aef1bb876dc8 (patch)
treeced2a033b5ff7a6d2d11ecf3d59efe3fab0b8f87 /app-text/epdfview/epdfview-0.1.6-r1.ebuild
parentBump to 0.60, closes #261183. Clean up old revisions. (diff)
downloadhistorical-e97c75096660077af96d7d6ef9f6aef1bb876dc8.tar.gz
historical-e97c75096660077af96d7d6ef9f6aef1bb876dc8.tar.bz2
historical-e97c75096660077af96d7d6ef9f6aef1bb876dc8.zip
Transition to eapi 2 use deps
Diffstat (limited to 'app-text/epdfview/epdfview-0.1.6-r1.ebuild')
-rw-r--r--app-text/epdfview/epdfview-0.1.6-r1.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/app-text/epdfview/epdfview-0.1.6-r1.ebuild b/app-text/epdfview/epdfview-0.1.6-r1.ebuild
index ac19419028be..cae44d9715a4 100644
--- a/app-text/epdfview/epdfview-0.1.6-r1.ebuild
+++ b/app-text/epdfview/epdfview-0.1.6-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/epdfview/epdfview-0.1.6-r1.ebuild,v 1.10 2009/02/26 19:35:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/epdfview/epdfview-0.1.6-r1.ebuild,v 1.11 2009/03/07 14:17:18 gentoofan23 Exp $
+EAPI="2"
inherit eutils
DESCRIPTION="Lightweight PDF viewer using Poppler and GTK+ libraries."
@@ -13,7 +14,7 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="cups nls test"
-COMMON_DEPEND=">=app-text/poppler-bindings-0.5.0
+COMMON_DEPEND=">=app-text/poppler-bindings-0.5.0[gtk]
>=x11-libs/gtk+-2.6
cups? ( >=net-print/cups-1.1 )"
DEPEND="${COMMON_DEPEND}
@@ -23,13 +24,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
nls? ( virtual/libintl )"
-pkg_setup() {
- if ! built_with_use app-text/poppler-bindings gtk; then
- eerror "Please re-emerge app-text/poppler-bindings with the gtk USE flag set."
- die "poppler-bindings needs gtk flag set."
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -38,12 +32,10 @@ src_unpack() {
epatch "${FILESDIR}/${P}-print-segfault.patch"
}
-src_compile() {
+src_configure() {
econf \
$(use_enable cups) \
- $(use_with nls) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_with nls)
}
src_install() {