summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-05-19 22:12:27 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-05-19 22:12:27 +0000
commit8af8a3d9bfac13939f785a0981ece4a6104a6c51 (patch)
tree5a152f14e90141330a7ee012bfeba6f7b9d92302 /app-text/glark
parentuse mask pam_console for now (diff)
downloadhistorical-8af8a3d9bfac13939f785a0981ece4a6104a6c51.tar.gz
historical-8af8a3d9bfac13939f785a0981ece4a6104a6c51.tar.bz2
historical-8af8a3d9bfac13939f785a0981ece4a6104a6c51.zip
New version
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-text/glark')
-rw-r--r--app-text/glark/ChangeLog8
-rw-r--r--app-text/glark/Manifest21
-rw-r--r--app-text/glark/files/1.7.3/glark-completion33
-rw-r--r--app-text/glark/files/digest-glark-1.7.31
-rw-r--r--app-text/glark/glark-1.7.3.ebuild32
5 files changed, 90 insertions, 5 deletions
diff --git a/app-text/glark/ChangeLog b/app-text/glark/ChangeLog
index a36c00ab015a..d19ac53fe953 100644
--- a/app-text/glark/ChangeLog
+++ b/app-text/glark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/glark
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.26 2005/04/24 11:36:20 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.27 2005/05/19 22:12:27 ciaranm Exp $
+
+*glark-1.7.3 (19 May 2005)
+
+ 19 May 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +files/1.7.3/glark-completion, +glark-1.7.3.ebuild:
+ New version
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> glark-1.7.2.ebuild:
Stable on ppc.
diff --git a/app-text/glark/Manifest b/app-text/glark/Manifest
index 204d1b1e2a7d..2fa3ec790668 100644
--- a/app-text/glark/Manifest
+++ b/app-text/glark/Manifest
@@ -1,9 +1,22 @@
-MD5 cc91d79e8dc6f0d1b9727eb83de5f98a metadata.xml 258
-MD5 6691d61f54590bee25f59ebb73fb2371 ChangeLog 3100
-MD5 1e06774f9e45e654f8d5b1bc9123fd03 glark-1.7.2.ebuild 757
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 7b52c023df30cd069791b32c06e52175 ChangeLog 3250
MD5 bf854935d15b7a1ace76e0972ba1122b glark-1.7.0.ebuild 671
MD5 d648bf0b3cbbf9b68ca48956fac22ebb glark-1.7.1.ebuild 675
-MD5 45ca54fe2662478c83bf160831b2aea9 files/digest-glark-1.7.1 62
+MD5 1e06774f9e45e654f8d5b1bc9123fd03 glark-1.7.2.ebuild 757
+MD5 cc91d79e8dc6f0d1b9727eb83de5f98a metadata.xml 258
+MD5 d99b39bdb18861f366a197da5064efdf glark-1.7.3.ebuild 763
MD5 16965b8cb4e088ce14ac964bf473d124 files/digest-glark-1.7.0 62
+MD5 45ca54fe2662478c83bf160831b2aea9 files/digest-glark-1.7.1 62
MD5 67bdc0662f2ad93234cf0299b10fb028 files/digest-glark-1.7.2 62
+MD5 4695391ede91f1ae074245c8ec21d36a files/digest-glark-1.7.3 62
MD5 a9e40de0df4455fd6614471416609b42 files/1.7.2/glark-completion 999
+MD5 09c80f210354b38b73388a8e5c43f3b9 files/1.7.3/glark-completion 1054
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCjQ9TLLFUmVNQ7rkRAkLYAKCmkusP+eepZF5tLVlOE2vGMakatACguZ8b
+zrG4fXZ7irnIRFiU2q0nsEg=
+=gIRn
+-----END PGP SIGNATURE-----
diff --git a/app-text/glark/files/1.7.3/glark-completion b/app-text/glark/files/1.7.3/glark-completion
new file mode 100644
index 000000000000..2a1c596f63dd
--- /dev/null
+++ b/app-text/glark/files/1.7.3/glark-completion
@@ -0,0 +1,33 @@
+# Author: Ciaran McCreesh <ciaranm@gentoo.org>
+#
+# completion for glark
+
+_glark()
+{
+ local cur prev
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=( $( compgen -W ' --directories --binary-files --basename \
+ --name --fullname --path --exclude-matching --recurse \
+ --split-as-path --no-split-as-path --and --before --after \
+ --file --ignore-case --match-limit --or --range \
+ --invert-match --word --word-regexp --line-regexp --xor \
+ --after-context --before-context --context --count \
+ --file-color --no-filter --grep --no-filename --with-filename \
+ --files-with-matches --files-without-match --line-number \
+ --no-line-number --line-number-color --text-color --highlight \
+ --no-highlight --extract-matches --null --help --config \
+ --explain --quiet --no-messages --no-quiet --version \
+ --verbose --label' -- $cur ) )
+ else
+ _filedir
+ fi
+}
+
+complete -o filenames -F _glark glark
+
+# vim: set ft=sh sw=4 et sts=4 :
diff --git a/app-text/glark/files/digest-glark-1.7.3 b/app-text/glark/files/digest-glark-1.7.3
new file mode 100644
index 000000000000..d31db1219cc5
--- /dev/null
+++ b/app-text/glark/files/digest-glark-1.7.3
@@ -0,0 +1 @@
+MD5 7fea78bd57431f252dcda40e1810607e glark-1.7.3.tar.gz 33409
diff --git a/app-text/glark/glark-1.7.3.ebuild b/app-text/glark/glark-1.7.3.ebuild
new file mode 100644
index 000000000000..e1246bd6163a
--- /dev/null
+++ b/app-text/glark/glark-1.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.7.3.ebuild,v 1.1 2005/05/19 22:12:27 ciaranm Exp $
+
+inherit bash-completion
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="http://glark.sourceforge.net/"
+SRC_URI="mirror://sourceforge/glark/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+# perl dep is for pod2man
+DEPEND="virtual/ruby
+ dev-lang/perl"
+RDEPEND="virtual/ruby"
+
+src_compile() {
+ emake
+ # force the manpage to be rebuilt
+ rm ${PN}.1
+ make ${PN}.1
+}
+
+src_install () {
+ make DESTDIR=${D} install
+ dobashcompletion ${FILESDIR}/${PV}/glark-completion ${PN}
+}
+