summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-10-08 14:11:40 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-10-08 14:11:40 +0000
commit957e00f5bc4f677b73d905366024ee6cc150fdd9 (patch)
tree1241e35dfca7c80231be590ae56fb093b2457ebb /app-text/poppler-bindings
parentBump. Dropping jpeg and zlib useflags because they only control whether to us... (diff)
downloadhistorical-957e00f5bc4f677b73d905366024ee6cc150fdd9.tar.gz
historical-957e00f5bc4f677b73d905366024ee6cc150fdd9.tar.bz2
historical-957e00f5bc4f677b73d905366024ee6cc150fdd9.zip
Bump. Go EAPI-2. Drop la files and static archives, not used. Dropping keywords for arm hppa ia64 m68k mips s390 sh sparc-fbsd cause they don't have openjpeg keyworded and poppler needs that. Implement alternative solution to stop building libpoppler.so using sed. Drop the stupid patch and use sed, so we don't have to keep the patch up-to-date. When cairo is enabled, gtk is now implicitly enabled also, since the cairo flag enables a feature of the gtk flag. Die if no use flags have been selected, or we wind up with empty package.
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64
Diffstat (limited to 'app-text/poppler-bindings')
-rw-r--r--app-text/poppler-bindings/ChangeLog15
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild82
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.9.3.ebuild117
3 files changed, 131 insertions, 83 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index b51a1af63927..76422a3ac775 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.107 2008/10/08 00:14:45 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.108 2008/10/08 14:11:40 loki_val Exp $
+
+*poppler-bindings-0.9.3 (08 Oct 2008)
+
+ 08 Oct 2008; Peter Alfredsen <loki_val@gentoo.org>
+ -poppler-bindings-0.9.2.ebuild, +poppler-bindings-0.9.3.ebuild:
+ Bump. Go EAPI-2. Drop la files and static archives, not used. Dropping
+ keywords for arm hppa ia64 m68k mips s390 sh sparc-fbsd cause they don't
+ have openjpeg keyworded and poppler needs that. Implement alternative
+ solution to stop building libpoppler.so using sed. Drop the stupid patch
+ and use sed, so we don't have to keep the patch up-to-date. When cairo is
+ enabled, gtk is now implicitly enabled also, since the cairo flag enables
+ a feature of the gtk flag. Die if no use flags have been selected, or we
+ wind up with empty package.
08 Oct 2008; Peter Alfredsen <loki_val@gentoo.org>
poppler-bindings-0.8.7.ebuild:
diff --git a/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild b/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild
deleted file mode 100644
index 05cc26420d4c..000000000000
--- a/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild,v 1.1 2008/09/27 00:37:56 compnerd Exp $
-
-EAPI="1"
-
-inherit autotools eutils multilib
-
-MY_P=${P/-bindings/}
-DESCRIPTION="rendering bindings for GUI toolkits for poppler"
-HOMEPAGE="http://poppler.freedesktop.org/"
-
-# Creating the testsuite tarball (must be done for every release)
-#
-# git://anongit.freedesktop.org/git/poppler/test
-# git archive --format=tar --prefix=test/ HEAD | bzip2 > ${PN}-test-${PV}.tar.bz2
-# upload to d.g.o/space/distfiles-local
-
-SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
- test? ( mirror://gentoo/poppler-test-0.9.2.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gtk qt3 cairo qt4 test"
-
-RDEPEND="~app-text/poppler-${PV}
- cairo? ( >=x11-libs/cairo-1.4 )
- gtk? (
- >=x11-libs/gtk+-2.8
- >=dev-libs/glib-2.8
- )
- qt3? ( =x11-libs/qt-3* )
- qt4? ( || ( ( x11-libs/qt-core:4
- x11-libs/qt-gui:4
- x11-libs/qt-test:4 )
- =x11-libs/qt-4.3*:4 ) )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- test? ( gtk? ( >=gnome-base/libglade-2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/poppler-0.6-bindings.patch
-
- AT_M4DIR="m4" eautoreconf
- cd poppler
- ln -s /usr/lib/libpoppler.la
-}
-
-src_compile() {
- # Configure needs help finding qt libs on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
- echo $QTLIB
-
- econf $(use_enable cairo cairo-output) \
- $(use_enable gtk poppler-glib) \
- $(use_enable qt3 poppler-qt) \
- $(use_enable qt4 poppler-qt4) \
- || die "configuration failed"
- cd poppler
- if use cairo; then
- emake libpoppler-cairo.la || die "cairo failed"
- fi
- if use qt4; then
- emake libpoppler-arthur.la || die "arthur failed"
- fi
- cd ..
- emake || die "compilation failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
-
-pkg_postinst() {
- ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
-}
diff --git a/app-text/poppler-bindings/poppler-bindings-0.9.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.9.3.ebuild
new file mode 100644
index 000000000000..c5d18599bea5
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.9.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.9.3.ebuild,v 1.1 2008/10/08 14:11:40 loki_val Exp $
+
+EAPI="2"
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org/"
+
+# Creating the testsuite tarball
+# must be done if upstream has added tests since last release.
+# can be checked at cgit.freedesktop.org
+#
+# git clone git://anongit.freedesktop.org/git/poppler/test
+# rm -rf test/.git
+# tar czf poppler-test-${PV}.tar.gz test
+
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
+ test? ( mirror://gentoo/poppler-test-0.9.2.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt3 cairo qt4 test"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? (
+ >=x11-libs/cairo-1.4
+ !gtk? (
+ >=x11-libs/gtk+-2.8
+ >=dev-libs/glib-2.8
+ )
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.8
+ >=dev-libs/glib-2.8
+ )
+ qt3? ( =x11-libs/qt-3* )
+ qt4? ( || ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4 )
+ =x11-libs/qt-4.3*:4 ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( gtk? ( >=gnome-base/libglade-2 ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! { use gtk || use qt3 || use qt4 || use cairo; }
+ then
+ eerror "You've selected to build no bindings for poppler."
+ eerror "Please select at least one of:"
+ eerror "gtk, qt3, qt4, cairo"
+ die "Please select a toolkit"
+ fi
+
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(top_builddir)/poppler/libpoppler.la:-lpoppler:' \
+ $(find . -name 'Makefile.am' ) || die "404"
+ sed -i \
+ -e '/libpoppler_la_LIBADD/,/win32_libs/d' \
+ -e '/libpoppler_la_SOURCES/,/XpdfPluginAPI.cc/d' \
+ -e '/libpoppler.la/d' \
+ -e '/libpoppler_la/d' \
+ poppler/Makefile.am || die "404"
+
+ sed -i \
+ -e '/if BUILD_SPLASH_OUTPUT/,/endif/d' \
+ -e '/poppler.pc\t/d' \
+ -e ':$(splash_pc_file):d' \
+ Makefile.am || die "404"
+
+ eautoreconf
+}
+
+src_configure() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf --disable-utils \
+ --disable-static \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt3 poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ $(use_enable cairo poppler-glib) \
+ $(use_enable cairo cairo-output) \
+ || die "configuration failed"
+}
+
+src_compile() {
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f $(find "${D}" -name '*.la')
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}