summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-07 08:59:34 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-07 08:59:34 +0000
commit85a482b7ba48271f5d418236bb14d2562ec9e5a1 (patch)
treebcbd50c4dd96ef6c99028661dbbceafe56d8db76 /app-text/rpl/rpl-1.5.5.ebuild
parentamd64 stable (bug #301519) (diff)
downloadhistorical-85a482b7ba48271f5d418236bb14d2562ec9e5a1.tar.gz
historical-85a482b7ba48271f5d418236bb14d2562ec9e5a1.tar.bz2
historical-85a482b7ba48271f5d418236bb14d2562ec9e5a1.zip
Version Bump #322255, thanks David Abbott for the ebuild
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-text/rpl/rpl-1.5.5.ebuild')
-rw-r--r--app-text/rpl/rpl-1.5.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/rpl/rpl-1.5.5.ebuild b/app-text/rpl/rpl-1.5.5.ebuild
new file mode 100644
index 000000000000..4f3c200b384e
--- /dev/null
+++ b/app-text/rpl/rpl-1.5.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rpl/rpl-1.5.5.ebuild,v 1.1 2010/06/07 08:59:34 jlec Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_install() {
+ distutils_src_install
+ doman ${PN}.1 || die
+}