summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-17 20:09:01 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-17 20:09:01 +0000
commitedb922e852b739112ecc3ddb87860795341b46ed (patch)
tree58dfe643938732cd21d8e151d8a4de43d638bc0b /app-text/sablotron
parent*** empty log message *** (diff)
downloadhistorical-edb922e852b739112ecc3ddb87860795341b46ed.tar.gz
historical-edb922e852b739112ecc3ddb87860795341b46ed.tar.bz2
historical-edb922e852b739112ecc3ddb87860795341b46ed.zip
*** empty log message ***
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/files/utf8.cpp2
-rw-r--r--app-text/sablotron/sablotron-0.44-r2.ebuild5
2 files changed, 4 insertions, 3 deletions
diff --git a/app-text/sablotron/files/utf8.cpp b/app-text/sablotron/files/utf8.cpp
index f617442c708a..5bcfccea6924 100644
--- a/app-text/sablotron/files/utf8.cpp
+++ b/app-text/sablotron/files/utf8.cpp
@@ -123,7 +123,7 @@ int utf8Recode(char* dest, const char* src, Encoding enc)
size_t outbytesleft = SMALL_BUFFER_SIZE;
char *outbuf = dest;
- cd = iconv_open (iconv_encoding[enc], "UTF-8");
+ cd = iconv_open (iconv_encoding[enc],"UTF-8");
assert(cd != (iconv_t)(-1));
while (inbytesleft &&
iconv(cd,(char **) &src, &inbytesleft, &outbuf, &outbytesleft) != -1);
diff --git a/app-text/sablotron/sablotron-0.44-r2.ebuild b/app-text/sablotron/sablotron-0.44-r2.ebuild
index c509f0dadce3..3624e7df728f 100644
--- a/app-text/sablotron/sablotron-0.44-r2.ebuild
+++ b/app-text/sablotron/sablotron-0.44-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.44-r2.ebuild,v 1.1 2000/11/14 14:38:48 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.44-r2.ebuild,v 1.2 2000/12/17 20:09:01 achim Exp $
A="Sablot-${PV}.tar.gz Sablot-Expat-1.1.2.tar.gz"
S=${WORKDIR}/Sablot-${PV}
@@ -17,11 +17,12 @@ src_unpack() {
unpack Sablot-${PV}.tar.gz
cd ${S}
unpack Sablot-Expat-1.1.2.tar.gz
- if [ -n "`use glibc22`" ]
+ if [ "`use glibc22`" ]
then
cp ${FILESDIR}/utf8.cpp Sablot/engine/
fi
}
+
src_compile() {
cd ${S}