summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-31 05:10:33 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-31 05:10:33 +0000
commit032ab024cde5d576965a1a2fc819e056bfa634f9 (patch)
tree922b943ea25579e9ec64a7e636306da63bce151c /app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild
parentgnuconfig update needed for atleast uclibc (diff)
downloadhistorical-032ab024cde5d576965a1a2fc819e056bfa634f9.tar.gz
historical-032ab024cde5d576965a1a2fc819e056bfa634f9.tar.bz2
historical-032ab024cde5d576965a1a2fc819e056bfa634f9.zip
version bumps and cleanups, stable x86 bump
Diffstat (limited to 'app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild')
-rw-r--r--app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild b/app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild
new file mode 100644
index 000000000000..7f0f74762f6a
--- /dev/null
+++ b/app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wpd2sxw/wpd2sxw-0.6.1.ebuild,v 1.1 2004/07/31 05:10:33 squinky86 Exp $
+
+DESCRIPTION="WordPerfect Document (wpd) to OpenOffice.org (sxw) converter"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.gz
+ perl? ( http://libwpd.sourceforge.net/wpd2sxwbatch.pl )"
+RESTRICT="nomirror"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="perl"
+DEPEND="gnome-extra/libgsf
+ >=app-text/libwpd-0.7.1
+ perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+ dobin ${DISTDIR}/wpd2sxwbatch.pl
+}