summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-04-15 12:36:19 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-04-15 12:36:19 +0000
commit4eb2c9e1de75df64078339b29d775554fdd049ba (patch)
treef6a7ee40ccd5edf130526321f7c2906011d6509b /app-text/wv2/wv2-0.4.2-r2.ebuild
parentStable for HPPA (bug #463614). (diff)
downloadhistorical-4eb2c9e1de75df64078339b29d775554fdd049ba.tar.gz
historical-4eb2c9e1de75df64078339b29d775554fdd049ba.tar.bz2
historical-4eb2c9e1de75df64078339b29d775554fdd049ba.zip
Migrate to EAPI 5. Add a patch to fix build failure with newer libgsf, wrt bug #465882.
Package-Manager: portage-2.1.11.62/cvs/Linux x86_64 Manifest-Sign-Key: 0x675D0D2C
Diffstat (limited to 'app-text/wv2/wv2-0.4.2-r2.ebuild')
-rw-r--r--app-text/wv2/wv2-0.4.2-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/wv2/wv2-0.4.2-r2.ebuild b/app-text/wv2/wv2-0.4.2-r2.ebuild
new file mode 100644
index 000000000000..4581dbb54a79
--- /dev/null
+++ b/app-text/wv2/wv2-0.4.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv2/wv2-0.4.2-r2.ebuild,v 1.1 2013/04/15 12:35:54 kensington Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
+HOMEPAGE="http://wvware.sourceforge.net"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="zlib"
+
+RDEPEND="dev-libs/glib
+ >=gnome-extra/libgsf-1.8:=
+ virtual/libiconv
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-glib.patch"
+ "${FILESDIR}/${P}-libgsf.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with zlib)
+ )
+ cmake-utils_src_configure
+}