summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2010-12-10 00:30:10 +0000
committerRyan Hill <rhill@gentoo.org>2010-12-10 00:30:10 +0000
commit032aca46e7a572b325fe86b2594a4befed6bbd92 (patch)
treecc08dd0221e5d4c7a273aca3dd7e92c74b871759 /app-text/xchm/xchm-1.18.ebuild
parentDrop ~ppc and ~ppc64 keywords due to unkeyworded gobject-introspection, bug #... (diff)
downloadhistorical-032aca46e7a572b325fe86b2594a4befed6bbd92.tar.gz
historical-032aca46e7a572b325fe86b2594a4befed6bbd92.tar.bz2
historical-032aca46e7a572b325fe86b2594a4befed6bbd92.zip
Version bump.
Package-Manager: portage-2.2.0_alpha7/cvs/Linux x86_64
Diffstat (limited to 'app-text/xchm/xchm-1.18.ebuild')
-rw-r--r--app-text/xchm/xchm-1.18.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-text/xchm/xchm-1.18.ebuild b/app-text/xchm/xchm-1.18.ebuild
new file mode 100644
index 000000000000..0e78a4c6d411
--- /dev/null
+++ b/app-text/xchm/xchm-1.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/xchm-1.18.ebuild,v 1.1 2010/12/10 00:30:10 dirtyepic Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets flag-o-matic fdo-mime gnome2-utils
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls"
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ econf ${myconf} \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}