summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-18 19:47:09 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-18 19:47:09 +0000
commitb3987222930481ef641f845a058c5b56d274e882 (patch)
treed6081c2e35f57fb279d56199743d36ffe9fbd357 /app-text/xmltex
parentAdded latest version of ESP ghostscript into portage. Currently masked (diff)
downloadhistorical-b3987222930481ef641f845a058c5b56d274e882.tar.gz
historical-b3987222930481ef641f845a058c5b56d274e882.tar.bz2
historical-b3987222930481ef641f845a058c5b56d274e882.zip
Modified xmltex-1.0-Makefile so xmltex and pdfxmltex are processed
properly. Closes bug #8075.
Diffstat (limited to 'app-text/xmltex')
-rw-r--r--app-text/xmltex/ChangeLog8
-rw-r--r--app-text/xmltex/files/xmltex-1.0-Makefile4
-rw-r--r--app-text/xmltex/xmltex-1.0.ebuild14
3 files changed, 20 insertions, 6 deletions
diff --git a/app-text/xmltex/ChangeLog b/app-text/xmltex/ChangeLog
index ea604313469e..92b810a0d433 100644
--- a/app-text/xmltex/ChangeLog
+++ b/app-text/xmltex/ChangeLog
@@ -1,14 +1,18 @@
# ChangeLog for app-text/xmltex
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmltex/ChangeLog,v 1.2 2002/08/02 17:42:50 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmltex/ChangeLog,v 1.3 2002/09/18 19:47:09 raker Exp $
*xmltex-1.0 (1 Feb 2002)
+ 18 Sep2002; Nick Hadaway <raker@gentoo.org> xmltex-1.0-Makefile,
+ xmltex-1.0.ebuild :
+ Updated the xmltex-1.0-Makefile so tetex install xmltex and pdfxmltex
+ properly. Closes bug #8075.
+
2 Aug 2002; phoen][x <phoenix@gentoo.org> xmltex-1.0.ebuild :
Added LICENSE, KEYWORDS.
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/app-text/xmltex/files/xmltex-1.0-Makefile b/app-text/xmltex/files/xmltex-1.0-Makefile
index 9dd88615d468..5bfba3609e64 100644
--- a/app-text/xmltex/files/xmltex-1.0-Makefile
+++ b/app-text/xmltex/files/xmltex-1.0-Makefile
@@ -1,10 +1,10 @@
default: xmltex.fmt pdfxmltex.fmt
xmltex.fmt:
- tex -ini "&latex" -progname=xmltex xmltex.ini
+ tex -ini "&latex" xmltex.ini
pdfxmltex.fmt:
- pdftex -ini "&pdflatex" -progname=pdfxmltex pdfxmltex.ini
+ pdftex -ini "&pdflatex" pdfxmltex.ini
install: xmltex.fmt pdfxmltex.fmt
(TT=$$DESTDIR/`kpsewhich -expand-var '$$TEXMFMAIN'`; \
diff --git a/app-text/xmltex/xmltex-1.0.ebuild b/app-text/xmltex/xmltex-1.0.ebuild
index ad497b3f291f..0d1ec6aad6fb 100644
--- a/app-text/xmltex/xmltex-1.0.ebuild
+++ b/app-text/xmltex/xmltex-1.0.ebuild
@@ -1,35 +1,45 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmltex/xmltex-1.0.ebuild,v 1.7 2002/08/16 02:42:02 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmltex/xmltex-1.0.ebuild,v 1.8 2002/09/18 19:47:09 raker Exp $
MY_P="base"
S=${WORKDIR}/${MY_P}
+
DESCRIPTION="A namespace-aware XML parser written in Tex"
SRC_URI="ftp://ftp.tex.ac.uk/tex-archive/macros/xmltex/${MY_P}.tar.gz"
HOMEPAGE="http://users.ox.ac.uk/~rahtz/passivetex/"
+
KEYWORDS="x86 sparc sparc64"
LICENSE="freedist"
+SLOT="0"
DEPEND="app-text/tetex"
-SLOT="0"
+RDEPEND="${DEPEND}"
src_compile() {
+
cp ${FILESDIR}/${P}-Makefile Makefile
+
make || die
+
}
src_install () {
make DESTDIR=${D} install || die
+
dodir /usr/bin
cd ${D}/usr/bin
ln -sf /usr/bin/virtex xmltex
ln -sf /usr/bin/pdfvirtex pdfxmltex
+
}
pkg_postinst() {
+
if [ -e /usr/bin/mktexlsr ]
then
/usr/bin/mktexlsr
fi
+
}