summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-15 15:04:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-15 15:04:22 +0000
commit2308d723b833d46f717842cf0059eb076fa1810a (patch)
tree4f0f8daf7b0b5c2d033097f117b481b435ad594d /app-text/xpdf/xpdf-9999.ebuild
parentx86 stable, bug #350765 (diff)
downloadhistorical-2308d723b833d46f717842cf0059eb076fa1810a.tar.gz
historical-2308d723b833d46f717842cf0059eb076fa1810a.tar.bz2
historical-2308d723b833d46f717842cf0059eb076fa1810a.zip
Add basic xpdf poppler live ebuild. So people might help upstream with development. Per bug #323469.
Package-Manager: portage-2.2.0_alpha15/cvs/Linux x86_64
Diffstat (limited to 'app-text/xpdf/xpdf-9999.ebuild')
-rw-r--r--app-text/xpdf/xpdf-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/xpdf/xpdf-9999.ebuild b/app-text/xpdf/xpdf-9999.ebuild
new file mode 100644
index 000000000000..5617b48665af
--- /dev/null
+++ b/app-text/xpdf/xpdf-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-9999.ebuild,v 1.1 2011/01/15 15:04:22 scarabeus Exp $
+
+EAPI=3
+
+EGIT_REPO_URI="https://github.com/rbrito/xpdf-poppler.git"
+inherit autotools autotools-utils git
+
+DESCRIPTION="An X Viewer for PDF Files - Poppler fork"
+HOMEPAGE="https://github.com/rbrito/xpdf-poppler"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ app-text/poppler[xpdf-headers]
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/openmotif
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+ autotools-utils_src_prepare
+}