summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-06-14 09:16:36 +0000
committerBen de Groot <yngwin@gentoo.org>2012-06-14 09:16:36 +0000
commit56f794473084c4e6191c811136c5c1fe587e835f (patch)
treeb2af7c489ff4d3e42dcee92e4704b43670743031 /app-text
parentStable for amd64, wrt bug #418661 (diff)
downloadhistorical-56f794473084c4e6191c811136c5c1fe587e835f.tar.gz
historical-56f794473084c4e6191c811136c5c1fe587e835f.tar.bz2
historical-56f794473084c4e6191c811136c5c1fe587e835f.zip
Version bump. Depend on qt-core[iconv] see bug #413653.
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'app-text')
-rw-r--r--app-text/qpdfview/ChangeLog7
-rw-r--r--app-text/qpdfview/qpdfview-0.3_beta3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-text/qpdfview/ChangeLog b/app-text/qpdfview/ChangeLog
index 956f234e3bec..c62fa7bcb255 100644
--- a/app-text/qpdfview/ChangeLog
+++ b/app-text/qpdfview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/qpdfview
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/qpdfview/ChangeLog,v 1.4 2012/06/12 05:00:26 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdfview/ChangeLog,v 1.5 2012/06/14 09:16:36 yngwin Exp $
+
+*qpdfview-0.3_beta3 (14 Jun 2012)
+
+ 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> +qpdfview-0.3_beta3.ebuild:
+ Version bump. Depend on qt-core[iconv] see bug #413653.
*qpdfview-0.3_beta2 (12 Jun 2012)
diff --git a/app-text/qpdfview/qpdfview-0.3_beta3.ebuild b/app-text/qpdfview/qpdfview-0.3_beta3.ebuild
new file mode 100644
index 000000000000..b532cdb524c8
--- /dev/null
+++ b/app-text/qpdfview/qpdfview-0.3_beta3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdfview/qpdfview-0.3_beta3.ebuild,v 1.1 2012/06/14 09:16:36 yngwin Exp $
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="A tabbed PDF viewer using the poppler library"
+HOMEPAGE="http://launchpad.net/qpdfview"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV/_}/+download/${P/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cups dbus"
+
+RDEPEND="app-text/poppler[qt4]
+ x11-libs/qt-core:4[iconv]
+ x11-libs/qt-gui:4
+ cups? ( net-print/cups )
+ dbus? ( x11-libs/qt-dbus:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README TODO"
+
+S=${WORKDIR}/${P/_}
+
+src_configure() {
+ local config
+
+ if ! use cups ; then
+ config+=" without_cups"
+ fi
+
+ if ! use dbus ; then
+ config+=" without_dbus"
+ fi
+
+ eqmake4 CONFIG+="${config}"
+}