summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-18 17:53:06 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-18 17:53:06 +0000
commit69e74d1dbb50512e5c6658693574facd9e166fed (patch)
treec2131e09eee3ecc5a4fdc32c9816dd6378e8800f /app-text
parentInitial import, closing Bug #29064 (diff)
downloadhistorical-69e74d1dbb50512e5c6658693574facd9e166fed.tar.gz
historical-69e74d1dbb50512e5c6658693574facd9e166fed.tar.bz2
historical-69e74d1dbb50512e5c6658693574facd9e166fed.zip
Initial import, closing Bug #29064
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pspresent/Manifest4
-rw-r--r--app-text/pspresent/files/digest-pspresent-1.11
-rw-r--r--app-text/pspresent/metadata.xml5
-rw-r--r--app-text/pspresent/pspresent-1.1.ebuild37
4 files changed, 46 insertions, 1 deletions
diff --git a/app-text/pspresent/Manifest b/app-text/pspresent/Manifest
index 945891f64276..b7deca8302a8 100644
--- a/app-text/pspresent/Manifest
+++ b/app-text/pspresent/Manifest
@@ -1,2 +1,4 @@
-MD5 1e8baf021939c46b83ba0e584597d142 pspresent-1.1.ebuild 757
+MD5 6b9f73962ad6b63ee8ae6cf7ca5e00a4 pspresent-1.1.ebuild 849
+MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
+MD5 458e58b1361b5fe2486a70b6add1eaa8 ChangeLog 407
MD5 e8d36b988969f7d4ff8e3a45e05ca0f3 files/digest-pspresent-1.1 64
diff --git a/app-text/pspresent/files/digest-pspresent-1.1 b/app-text/pspresent/files/digest-pspresent-1.1
new file mode 100644
index 000000000000..719e257ef0e3
--- /dev/null
+++ b/app-text/pspresent/files/digest-pspresent-1.1
@@ -0,0 +1 @@
+MD5 84a0fb55c8231a14cebfc4e8ee35b853 pspresent-1.1.tar.gz 14352
diff --git a/app-text/pspresent/metadata.xml b/app-text/pspresent/metadata.xml
new file mode 100644
index 000000000000..20ce219711a2
--- /dev/null
+++ b/app-text/pspresent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+</pkgmetadata>
diff --git a/app-text/pspresent/pspresent-1.1.ebuild b/app-text/pspresent/pspresent-1.1.ebuild
new file mode 100644
index 000000000000..1a4abdb5eab1
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.1.ebuild,v 1.1 2003/09/18 17:53:02 usata Exp $
+
+IUSE="xinerama"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A tool to display full-screen PostScript presentations."
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-apps/sed-4
+ app-text/ghostscript"
+RDEPEND="virtual/glibc
+ virtual/x11
+ app-text/ghostscript"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile()
+{
+ if [ ! "`use xinerama`" ] ; then
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile
+ fi
+ make pspresent || die "make failed"
+}
+
+src_install()
+{
+ dobin pspresent
+ doman pspresent.1
+ dodoc COPYING
+}