summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-17 19:42:35 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-17 19:42:35 +0000
commit9cf9866f708d99eb700fe6e8e1102c9d6dbc3b4a (patch)
tree5e271852e7aaa16e322ca6d0214800e0d519261d /app-text
parentMarking stable. This has been very well tested and resolves quite a few issu... (diff)
downloadhistorical-9cf9866f708d99eb700fe6e8e1102c9d6dbc3b4a.tar.gz
historical-9cf9866f708d99eb700fe6e8e1102c9d6dbc3b4a.tar.bz2
historical-9cf9866f708d99eb700fe6e8e1102c9d6dbc3b4a.zip
Fix chmod thanks to Alexander Skwar <askwar@digitalprojects.com> in bug 118015
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/acroread/ChangeLog5
-rw-r--r--app-text/acroread/Manifest14
-rw-r--r--app-text/acroread/acroread-7.0.5.ebuild11
3 files changed, 13 insertions, 17 deletions
diff --git a/app-text/acroread/ChangeLog b/app-text/acroread/ChangeLog
index b47b19ac86e6..f71de84b3723 100644
--- a/app-text/acroread/ChangeLog
+++ b/app-text/acroread/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/acroread
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.67 2006/01/12 12:51:22 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.68 2006/01/17 19:42:35 genstef Exp $
+
+ 17 Jan 2006; Stefan Schweizer <genstef@gentoo.org> acroread-7.0.5.ebuild:
+ Fix chmod thanks to Alexander Skwar <askwar@digitalprojects.com> in bug 118015
*acroread-7.0.5-r1 (12 Jan 2006)
diff --git a/app-text/acroread/Manifest b/app-text/acroread/Manifest
index f3c799e3569c..c337f2568021 100644
--- a/app-text/acroread/Manifest
+++ b/app-text/acroread/Manifest
@@ -1,21 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 e7787b3ede04cd3c0812d4a2d16d7240 ChangeLog 12383
+MD5 330e36adf41c3fa722f61f19094891a3 ChangeLog 12543
MD5 520bad9028981b2837696c4f7a4f84b4 acroread-5.10.ebuild 2511
MD5 7c177b350d5c17994dd80569e0fcdb22 acroread-7.0.1.1.ebuild 3439
MD5 68763d7f3b08b45fb429226bfcb531d8 acroread-7.0.5-r1.ebuild 2882
-MD5 8461462ce3069335bc32373c453e16a5 acroread-7.0.5.ebuild 2679
+MD5 458977f344d5b207b3e2f4ffcb18ee7e acroread-7.0.5.ebuild 2881
MD5 00414d6be2296740cc5225ca93a3d035 files/acroread-scim.patch 488
MD5 d0981fc5a58874b78a6f2a2b73d3e43d files/digest-acroread-5.10 63
MD5 56c836a11cd417c3694a90f2c1ccfef9 files/digest-acroread-7.0.1.1 1185
MD5 c7f8b023e5f98d120c27778a2b2184b7 files/digest-acroread-7.0.5 395
MD5 a7710a4939e2b52a8c5f42df6ab4a49e files/digest-acroread-7.0.5-r1 458
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDxlDe2G5bA0cA/ScRAjgKAKC6KMKf3jK8pWYqLkBdiNmdwEw4QACfaZ2p
-P7VBeBSnHqjNTJpaHOuApbs=
-=+Baw
------END PGP SIGNATURE-----
diff --git a/app-text/acroread/acroread-7.0.5.ebuild b/app-text/acroread/acroread-7.0.5.ebuild
index ca0068b14a9d..7b5d2d5f9154 100644
--- a/app-text/acroread/acroread-7.0.5.ebuild
+++ b/app-text/acroread/acroread-7.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.5.ebuild,v 1.4 2006/01/11 11:47:57 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.5.ebuild,v 1.5 2006/01/17 19:42:35 genstef Exp $
inherit eutils nsplugins rpm versionator
@@ -56,14 +56,17 @@ src_install() {
for i in ${DIRS}
do
if [ -d ${i} ] ; then
- chown -R --dereference root:0 ${i}
+ chown -R --dereference -L root:0 ${i}
mv ${i} ${D}${INSTALLDIR}
fi
done
exeinto ${INSTALLDIR}
doexe bin/acroread || die "doexe failed"
- dodoc Browser/Browser_Plugin_HowTo.txt
+ # The Browser_Plugin_HowTo.txt is now in a subdirectory, which
+ # is named according to the language the user is using.
+ # Ie. for German, it is in a DEU directory. See bug #118015
+ #dodoc Browser/${LANG_TAG}/Browser_Plugin_HowTo.txt
if use nsplugin ; then
exeinto /opt/netscape/plugins
@@ -86,7 +89,7 @@ src_install() {
pkg_postinst () {
# fix wrong directory permissions (bug #25931)
- find ${INSTALLDIR} -type d | xargs chmod 755 || die
+ find ${INSTALLDIR}/. -type d | xargs chmod 755 || die
einfo "The Acrobat(TM) Security Plugin will be enabled with USE=ldap"
einfo "The Acrobat(TM) Browser Plugin will be enabled with USE=nsplugin"