summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-09 18:30:54 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-09 18:30:54 +0000
commit9dbd61e0b8e403a6e545b63fd10c6a4ff8a0e97d (patch)
treea40e78195747a746a364da0e5f17584390c1eec5 /app-text
parentversion bump, thanks to me (diff)
downloadhistorical-9dbd61e0b8e403a6e545b63fd10c6a4ff8a0e97d.tar.gz
historical-9dbd61e0b8e403a6e545b63fd10c6a4ff8a0e97d.tar.bz2
historical-9dbd61e0b8e403a6e545b63fd10c6a4ff8a0e97d.zip
added warnings for curl support (bug #47318)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibletime/ChangeLog5
-rw-r--r--app-text/bibletime/Manifest4
-rw-r--r--app-text/bibletime/bibletime-1.4.1.ebuild38
3 files changed, 42 insertions, 5 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 6dc5d0879d5b..f198f9d9af01 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-text/bibletime
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.8 2004/04/08 22:23:45 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.9 2004/04/09 18:30:54 squinky86 Exp $
*bibletime-1.4.1 (04 Apr 2004)
+ 09 Apr 2004; Jon Hood <squinky86@gentoo.org>:
+ added pre and post install information for curl support. (bug #47318)
+
04 Apr 2004; Jon Hood <squinky86@gentoo.org> bibletime-1.4.1.ebuild:
version bump, thanks to Timothy Stotts for the ebuild, bug #39300
diff --git a/app-text/bibletime/Manifest b/app-text/bibletime/Manifest
index e65d2dd8cdcb..16e9f3e0f25b 100644
--- a/app-text/bibletime/Manifest
+++ b/app-text/bibletime/Manifest
@@ -1,6 +1,6 @@
-MD5 30ea70cc22f2c21160780f557ca42b90 bibletime-1.4.1.ebuild 543
+MD5 ffd23a40add203db4d0118673ebfdf76 bibletime-1.4.1.ebuild 1694
MD5 dc0bf407d825545bea6c576500459c16 bibletime-1.3.ebuild 539
-MD5 f3c0eac660d3f424011b4ad887f7eafa ChangeLog 1244
+MD5 7048616b2741b8e7c8428e1d20c89a60 ChangeLog 1365
MD5 7dd41037409fd066de5c5975ba1b7743 metadata.xml 494
MD5 58df8cea249042acc8089846abd5db85 files/digest-bibletime-1.4.1 69
MD5 0d95b85fcac9fe17b4ab19588c91c6b5 files/digest-bibletime-1.3 66
diff --git a/app-text/bibletime/bibletime-1.4.1.ebuild b/app-text/bibletime/bibletime-1.4.1.ebuild
index 7cd8eb5b3ca0..151d6826e640 100644
--- a/app-text/bibletime/bibletime-1.4.1.ebuild
+++ b/app-text/bibletime/bibletime-1.4.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.4.1.ebuild,v 1.1 2004/04/08 22:20:25 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.4.1.ebuild,v 1.2 2004/04/09 18:30:54 squinky86 Exp $
inherit kde
need-kde 3
-IUSE=""
+IUSE="curl"
DESCRIPTION="BibleTime KDE Bible study application using the SWORD library."
HOMEPAGE="http://bibletime.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -14,3 +14,37 @@ SLOT="0"
KEYWORDS="~x86 ~ppc"
newdepend ">=app-text/sword-1.5.7
>=net-misc/curl-7.10"
+
+pkg_preinst() {
+ if [ ! "`use curl`" ] ; then
+ ewarn
+ ewarn "You do not have \"curl\" support enabled in your USE variable."
+ ewarn "This means SWORD may not have been compiled with curl support."
+ ewarn "If you wish to use BibleTime's ability to download modules"
+ ewarn "straight from the SWORD website, please add \"curl\" to your"
+ ewarn "USE variable in /etc/make.conf or make sure app-text/sword was"
+ ewarn "compiled with support for curl:"
+ ewarn " USE=\"curl\" emerge sword"
+ ewarn "Press ctrl+c to abort the merge of BibleTime if you want to"
+ ewarn "recompile SWORD with curl support."
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+ fi
+}
+
+pkg_postinst() {
+ if [ `use curl` ] ; then
+ einfo
+ einfo "To use BibleTime's ability to install modules from"
+ einfo "The SWORD Project's website, make sure that SWORD"
+ einfo "was compiled with curl support, either by making"
+ einfo "sure the \"curl\" USE flag is set in /etc/make.conf"
+ einfo "or by installing SWORD with:"
+ einfo " USE=\"curl\" emerge sword"
+ einfo
+ fi
+}