summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 21:28:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 21:28:44 +0000
commite78fa36df38c058d112ea552333b66586aa93730 (patch)
tree6deea35c55598153d4052a8bf804c914936e097d /app-text
parentAdd ~alpha and ~ia64 (diff)
downloadhistorical-e78fa36df38c058d112ea552333b66586aa93730.tar.gz
historical-e78fa36df38c058d112ea552333b66586aa93730.tar.bz2
historical-e78fa36df38c058d112ea552333b66586aa93730.zip
add inherit eutils
Diffstat (limited to 'app-text')
-rw-r--r--app-text/aiksaurus/aiksaurus-1.0.1.ebuild13
-rw-r--r--app-text/aspell/aspell-0.50.4.1.ebuild21
2 files changed, 14 insertions, 20 deletions
diff --git a/app-text/aiksaurus/aiksaurus-1.0.1.ebuild b/app-text/aiksaurus/aiksaurus-1.0.1.ebuild
index 8fe0da87d5ec..1a2e187b2aa1 100644
--- a/app-text/aiksaurus/aiksaurus-1.0.1.ebuild
+++ b/app-text/aiksaurus/aiksaurus-1.0.1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aiksaurus/aiksaurus-1.0.1.ebuild,v 1.3 2004/03/12 08:45:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aiksaurus/aiksaurus-1.0.1.ebuild,v 1.4 2004/04/07 21:26:49 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="A thesaurus lib, tool and database"
+HOMEPAGE="http://sourceforge.net/projects/aiksaurus"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://sf.net/projects/aiksaurus"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
DEPEND="sys-devel/gcc"
@@ -21,15 +21,12 @@ src_unpack() {
}
src_compile() {
-
filter-flags -fno-exceptions
-
- cd ${S}
econf || die
emake || die
}
src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING README* ChangeLog
+ dodoc AUTHORS README* ChangeLog
}
diff --git a/app-text/aspell/aspell-0.50.4.1.ebuild b/app-text/aspell/aspell-0.50.4.1.ebuild
index b7fcda042488..d28572eb69d3 100644
--- a/app-text/aspell/aspell-0.50.4.1.ebuild
+++ b/app-text/aspell/aspell-0.50.4.1.ebuild
@@ -1,30 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.4.1.ebuild,v 1.6 2004/04/02 19:15:09 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.4.1.ebuild,v 1.7 2004/04/07 21:28:44 vapier Exp $
-inherit libtool
+inherit libtool flag-o-matic eutils
DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
SRC_URI="http://aspell.net/${P}.tar.gz"
-IUSE="gpm"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa -amd64 ia64"
+IUSE="gpm"
DEPEND=">=sys-libs/ncurses-5.2
gpm? ( sys-libs/gpm )"
-pkg_setup() {
- if [ ${ARCH} = "ppc" ] ; then
- CXXFLAGS="-O2 -fsigned-char"
- CFLAGS=${CXXFLAGS}
- fi
- use gpm && LDFLAGS="-lgpm"
-}
-
src_compile() {
+ if [ "${ARCH}" == "ppc" ] ; then
+ export CXXFLAGS="-O2 -fsigned-char"
+ export CFLAGS="${CXXFLAGS}"
+ fi
+ use gpm && append-ldflags -lgpm
epatch ${FILESDIR}/01-gcc3.3-assert.patch
elibtoolize --reverse-deps